0

I have RHEL in a test environment and I wanted to install a program that initiates a script that mandates java. The script tests for Java binaries folder.

I tried first to choose the java/bin directory but it said there are no executables in that directory. I tried many things including installing and uninstalling Java. Now I realized I should choose the parent Java folder that has bin/ and lib/ as child directories. When I tried to choose this directory now it says the JRE is not compatible with the software I am trying to install.

The software I want to install uses 32bit of Java. I think the one I have now is 64 bit Java.

I downloaded the 32bit version of Java 1.7 and installed it by rpm and it said it is installed successfully but I can't actually find it. I get same problem when I try to run my script that java is not compatible.

How can I make sure that Java is installed in 32bit not in 64bit in the desired location?

There is a java file in /etc/alternatives/java_sdk/bin but when I try to issue java -version I get:

[root@localhost bin]# ./java -version
Error: could not find libjava.so
Error: Could not find Java SE Runtime Environment.
  • This is really funny. Java was created to avoid architecture issues and then, some troll company/programmer creates a Java-based software that requires 32bit Java instead of using the system one... – user34720 Jan 6 '16 at 10:49
0

Try:

alternatives --config java

and choose version of Java you want to use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.