3

I prefer to have capslock as control. On startup of my session I perform

setxkbmap -layout us -variant altgr-intl -option compose:menu,ctrl:nocaps

which does that for me. On every suspend this information is lost again. The script has to be run again which I bundled together with my locking script.

There are a couple corner cases where it is still reset. So I would like to make my favorite layout the system wide default such that I do not have to occasionally scream as my control key (which has “capslock” printed on it) does not work any more.

The system is Fedora 23.

Can I set the system wide default layout to the exact layout I have when I run with setxkbmap command? If now, how would I construct such a layout?

5

Assuming you are using Fedora Workstation (or the GNOME desktop environment in another way), the easiest approach is to install the Tweak Tool (search in Software, or sudo dnf install gnome-tweak-tool from the command line).

In that applet, under Typing (weirdly not "Keyboard and Mouse"), there's a section called "Ctrl key position", with choices including

  • Swap Ctrl and Caps Lock
  • Caps Lock as Ctrl

For Version 3.26.4 of that applet, the above option is under "Keyboard and Mouse", then look for "Additional Layout Options".

Or (brought to us by the Department of Redundancy Department?), in the "Caps Lock key behavior" section, there's also an option for Make Caps lock an additional Ctrl.

  • 2
    Sorry, I do not use any desktop environment, I use plain Awesome. – Martin Ueding Jan 5 '16 at 22:29
  • 2
    Stuff like this is why we have desktop environments, you know.:) – mattdm Jan 5 '16 at 22:58
-1

It has moved, but still there F29:

**Swap CapsLock & Ctrl TweakTool| Keyboard&Mouse | AdditionalLayoutOptions | Ctrlposition | swap Ctrl&Caps Lock

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.