1

I have just upgraded my PC. It was an old intel Q8400 with an nvidia graphics card. I changed the CPU (now an i3-6300) + Motherboard, and ditched the graphics card (want to use intel's graphics card that comes with the CPU).

Now, however, I get the message that Cinnamon is running without video hardware acceleration, and everything on screen is "laggy". I also have a dual monitor setup and when I go to system settings -> display I only see one display named as "laptop". Display detection does not work, and they are mirrored. Logically it has to do with the drivers.

Based on this thread I should look for a related xorg.conf file, but there seems to be none related (below are my xorg.conf file search results)

/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/10-quirks.conf
/usr/share/X11/xorg.conf.d/11-evdev-quirks.conf
/usr/share/X11/xorg.conf.d/11-evdev-trackpoint.conf
/usr/share/X11/xorg.conf.d/50-synaptics.conf
/usr/share/X11/xorg.conf.d/50-vmmouse.conf
/usr/share/X11/xorg.conf.d/50-wacom.conf
/usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf
/usr/share/man/man5/xorg.conf.5.gz
/usr/share/man/man5/xorg.conf.d.5.gz

Update

System info based on Inxi (seems like intel drivers are actually being used)

System: Host: HomePC Kernel: 3.16.0-38-generic x86_64 (64 bit) Desktop: Cinnamon 2.6.13 Distro: Linux Mint 17.2 Rafaela Machine:
Mobo: ASUSTeK model: B150M-C version: Rev X.0x serial: 151055956202383 Bios: American Megatrends version: 0402 date: 09/25/2015 CPU: Dual core Intel Core i3-6300 CPU (-HT-MCP-) clocked at 760.00 MHz Graphics: Card: Intel Device 1912 X.org: 1.15.1 drivers: fbdev,intel (unloaded: vesa) tty size: 80x24 Advanced Data: N/A for root Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169 Drives: HDD Total Size: 256.1GB (6.7% used) Info:
Processes: 215 Uptime: 1 min Memory: 1472.4/15928.1MB Client: Shell (bash) inxi: 1.9.17

0

I had trouble with my own machine when I installed an NVidia driver but couldn't get it to work with cinnamon. I had to use my old intel drivers for cinnamon. The xorg.conf file automatically defaulted to the NVidia driver, so I had to manually change the driver, but then I got this hardware acceleration issue.

The fix I performed for this issue was: in /etc/X11/xorg.conf, delete the line that says Option "AccelMethod" "None".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.