2

I have a home.mount unit that mounts my home directory to a partition different than what I wish. Things I have tried:

  • Using fstab to override it. However, fstab does not mount /home unless I type "mount /home" at the command prompt after each boot.

  • Masking home.mount unit. However, after reboot its status shows "masked active mounted": no change in behaviour.

  • Disabling home.mount. However, only unit files can be disabled; since I do not know which unit file home.mount corresponds to, I was not able to disable it.

  • Deleting home.mount. However, no home.mount file is found in the whole /.

  • Getting status of home.mount to see if it's possible to modify it. The only file its status references is, /proc/self/mountinfo; and, that is not a modifiable file.

How can I mount my home directory as I wish? I have Fedora 18.

Exact info, in case someone can interpret something:

Id=home.mount
Names=home.mount
Conflicts=umount.target
Before=local-fs.target
Description=home.mount
LoadState=masked
ActiveState=active
SubState=mounted
FragmentPath=/dev/null
SourcePath=/proc/self/mountinfo
InactiveExitTimestamp=Tue 2013-01-01 08:44:59 GMT
InactiveExitTimestampMonotonic=14108083
ActiveEnterTimestamp=Tue 2013-01-01 08:44:59 GMT
ActiveEnterTimestampMonotonic=14108083
ActiveExitTimestampMonotonic=0
InactiveEnterTimestampMonotonic=0
CanStart=yes
CanStop=yes
CanReload=yes
CanIsolate=no
StopWhenUnneeded=no
RefuseManualStart=no
RefuseManualStop=no
AllowIsolate=no
DefaultDependencies=yes
OnFailureIsolate=no
IgnoreOnIsolate=yes
IgnoreOnSnapshot=no
NeedDaemonReload=yes
JobTimeoutUSec=0
ConditionTimestampMonotonic=0
ConditionResult=no
Where=/home
What=mtd0
Options=rw,relatime,rw,rp_size=4096
Type=jffs2
TimeoutUSec=1min 30s
ControlPID=0
DirectoryMode=0755
Result=success
UMask=0022
LimitCPU=18446744073709551615
LimitFSIZE=18446744073709551615
LimitDATA=18446744073709551615
LimitSTACK=18446744073709551615
LimitCORE=18446744073709551615
LimitRSS=18446744073709551615
LimitNOFILE=65536
LimitAS=18446744073709551615
LimitNPROC=1714
LimitMEMLOCK=65536
LimitLOCKS=18446744073709551615
LimitSIGPENDING=1714
LimitMSGQUEUE=819200
LimitNICE=0
LimitRTPRIO=0
LimitRTTIME=18446744073709551615
OOMScoreAdjust=0
Nice=0
IOScheduling=0
CPUSchedulingPolicy=0
CPUSchedulingPriority=0
TimerSlackNSec=50000
CPUSchedulingResetOnFork=no
NonBlocking=no
StandardInput=null
StandardOutput=journal
StandardError=inherit
TTYReset=no
TTYVHangup=no
TTYVTDisallocate=no
SyslogPriority=30
SyslogLevelPrefix=yes
SecureBits=0
CapabilityBoundingSet=18446744073709551615
MountFlags=0
PrivateTmp=no
PrivateNetwork=no
SameProcessGroup=yes
ControlGroupModify=no
ControlGroupPersistent=no
IgnoreSIGPIPE=yes
NoNewPrivileges=no
KillMode=control-group
KillSignal=15
SendSIGKILL=yes
  • 1
    from man systemd.mount: mount points created at runtime (independently of unit files or /etc/fstab) will be monitored by systemd and appear like any other mount unit in systemd. See /proc/self/mountinfo description in proc(5). but i dunno what that means - why would they be created at runtime? what might cause it? im looking through it a little more now... seems weird, though. maybe its an automatically generated dependency of some other service or unit or something... seriously, systemd is mammoth. maybe its because you did the mount, though? didn't you say you did that? – mikeserv Jan 5 '16 at 7:46
  • Fedora 18 is EOL for quite some time. You should update. – Jakuje Jan 5 '16 at 9:56
  • @Jakuje Unfortunately, Fedora 18 was customized for this device. Even doing yum update all bricks the device, because it replaces some package with a version too updated for the device, and it segfaults at next boot. So updating is not an option. – Alex Jan 5 '16 at 14:55
  • 1
    not too updated for the device, usually, but for the kernel, or other non-kept modules. are there weird modules on it? if the device needs special, proprietary drivers you might be stuck, but bitching at the vendor can be helpful. just do a whole installation - if any. – mikeserv Jan 5 '16 at 15:01
  • @mikeserv The modules on it are not "custom", just standard modules tweaked to take up less RAM, less storage, etc.; I suspect that it is the drivers that are the problem. The vendor stopped supporting this hardware in US a few years ago, possibly because people could not update past 18. p.s., when do you sleep? You posted after I went to sleep, and I posted right after waking up, even before breakfast, and you are also awake already. – Alex Jan 5 '16 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.