3

I have NixOS built using 15.09 channel, session manager is sddm, display manager is KDE 5.

Switching to virtual ttys from 1 to 6 gives me no login prompt, I see same piece of log everywhere:

<<< NixOS Stage 2>>>

Running activation script...
setting up /etc...
warning: not applying UID change of user ntp
starting systemd...

Is it expected behaviour with systemd or it could be fixed?

  • I'm rather confident none of these log messages is really related to the problem you experience. – Vladimír Čunát Jan 6 '16 at 23:33
  • @Neználek you're right, I've figured this out a bit late – Geradlus_RU Jan 7 '16 at 10:09
4

In my case the issue was related to proprietary nvidia drivers. I've rebuilt system without nvidia driver and now I can login to tty from 1 to 6 as expected.

The issue seems is related to conjunction of Nvidia driver with Intel CPU with integrated graphics, virtual tty login screens are being redirected to motherboard video output. If this is the case you one possible solution is to blacklist i915 module.

On NixOS you need to add following line to your configuration.nix:

boot.blacklistedKernelModules = [ "i915" ];

On other distros this would be similar to (original discussion):

echo "blacklist i915" > /etc/modprobe.d/blacklist-intelGraphics.conf 
update-initramfs -u 
  • What if I want to use the Nvidia graphics drivers? I just black list the intel driver? Is this a case where the 2 drivers are competing? – CMCDragonkai Jan 17 '16 at 7:32
  • @CMCDragonkai blacklisting Intel driver is optional and required only to fix issue with virtual ttys. If you're on NixOS installation of nvidia-drivers is quite easy, see superuser.com/a/914041/252187 (for some reason I can't find a wiki article which I've used in past). – Geradlus_RU Jan 17 '16 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.