2

I am computer savvy, but fairly new to Linux, so forgive me if not technical enough.

I have a 3TB external HDD, a Seagate, and it used to be a NAS, but the Ethernet portion failed, so I have plugged it directly into my desktop computer via SATA interface. The desktop is maybe 5 years old, Athlon dual core 4 GB RAM, etc. I set it up to dual boot Windows 7 and a yet to be decided Linux distro.

So I am trying Knoppix, the most current version, and I am running it from a live USB stick:

  • I can see the HDD,
  • it has several partitions on it,
  • the main one is LVM2,
  • but I can't mount it.

The drive has data on it that I am trying to access.

I have searched around the internet, including this forum, and found some helpful suggestions regarding LVM, but nothing seems to work. I still can't mount it or access the data on it, as everything I try results in an error. How can I access this HDD?

I can provide any additional info, as required.

update

root@Microknoppix:/home/knoppix# vgchange -ay vg1
/run/lvm/lvmetad.socket: connect failed: No such file or directory
WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
1 logical volume(s) in volume group "vg1" now active

mkdir /mnt/tmp
mount /dev/vg1/lv1 /mnt/tmp
mount: wrong fs type, bad option, bad superblock on /dev/mapper/vg1-lv1, missing codepage or helper program, or other error
In Some cases useful info is found in syslog - try dmesg | tail or so

Update Ok, thank you @Hauke, i tried using your command and got the same error:

mount: wrong fs type, bad option, bad superblock on /dev/mapper/vg1-lv1,
missing codepage or helper program, or other error
in some cases info is found in syslog - try dmesg | tail or so

Any ideas?

2
  • I ran into this exact scenario today seagate central nas with failed network port. simplest lvm setup you can imagine, but impossible to mount the ext4 filesystem even though I can't find any tool that reports an error. I ended up pulling the files I needed using debugfs
    – Enetheru
    Sep 25, 2020 at 3:33
  • found reason in dmesg "bad block size 65536" others have reported mounting via fuse to overcome this.
    – Enetheru
    Sep 25, 2020 at 3:50

1 Answer 1

0

You probably have forgotten to activate the volumes ("normal" distros activate everything but live distros do not). You can either activate a whole volume group (even if you do not need all volumes) with

vgchange -ay vgname

or just the logical volumes you need with

lvchange -ay vgname/lvname

lvs shows you which volumes are active (the a column). Run it before and after the above command for comparison.

4
  • I tried and this is what I got:
    – Scott A
    Jan 5, 2016 at 16:01
  • root@Microknoppix:/home/knoppix# vgchange -ay vg1 /run/lvm/lvmetad.socket: connect failed: No such file or directory WARNING: Failed to connect to lvmetad. Falling back to internal scanning. 1 logical volume(s) in volume group "vg1" now active Do I now try to mount it? Can you please tell me how to do the command?
    – Scott A
    Jan 5, 2016 at 16:08
  • mkdir /mnt/tmp mount /dev/vg1/lv1 /mnt/tmp mount: wrong fs type, bad option, bad superblock on /dev/mapper/vg1-lv1, missing codepage or helper program, or other error In Some cases useful info is found in syslog - try dmesg | tail or so
    – Scott A
    Jan 5, 2016 at 16:18
  • @ScottA You should usually put such bis command output as edit into your question because it is much easier to read than in a comment. The mount problem is not related to your LVM problem; you just used the wrong command. You need: mount -t auto /dev/vg1/lv1 /mnt/tmp Jan 5, 2016 at 18:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .