I'm setting up a new linux server and have installed VSFTPD. I can login to FTP fine using the root user, but not using my new user "AMP". I'm using the same password I'd use to login as AMP in SSH so it's not a wrong password.

I've looked around and found there is a userlist setting... but I've set it to NO hoping that means I don't have to worry about user lists at all. AMP has a home folder set (/home/AMP)... I'm a bit lost here. I'm sure it's something simple... anyone have any ideas?

# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.

# This directive enables listening on IPv6 sockets. By default, listening
# on the IPv6 "any" address (::) will accept connections from both IPv6
# and IPv4 clients. It is not necessary to listen on *both* IPv4 and IPv6
# sockets. If you want that (perhaps because you want to listen on specific
# addresses) then you must run two copies of vsftpd with two configuration
# files.
# Allow anonymous FTP? (Disabled by default).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.

1 Answer 1


Found the answer here -

New local user can't login to vsftpd

Added the /bin/false shell to my user in /etc/passwd ... and then added that shell to the list in /etc/shells. Tried to login and it worked!!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .