3

I'm using Ubuntu 15.10

Problem:
For some days now I have been getting Errors like this when opening some applications:

/usr/lib/x86_64-linux-gnu/libpoppler-qt5.so.1: undefined symbol: _ZN6QDebugD1Ev

Some applications affected are

  • texstudio shows
    /usr/lib/x86_64-linux-gnu/libpoppler-qt5.so.1: undefined symbol: _ZN6QDebugD1Ev
  • IPython's qtconsole shows
    /usr/lib/python3.5/site-packages/PyQt5/QtCore.so: undefined symbol: _ZNK12QStorageInfo11displayNameEv
  • konsole (KDE's terminal emulator - I'm using Unity though) shows /usr/lib/x86_64-linux-gnu/libKF5ItemViews.so.5: undefined symbol: ...
  • granatier (a KDE game), KSysguard and KAddressbook also show errors in KF5 libraries
  • also fail
  • VLC seems to be affected too since it says there is something wrong with Qt 4 (see below)

Qt
all of this errors seem to come from Qt linked libraries ("Qt" appears in most filenames and most symbol names). AFAIK KDE ist baed on Qt, which would explain why all KDE applications fail.
It seems to affect both Qt 4 and 5

Possible Origin
The day this problems appeared I had enabled wily-proposed packages in the Ubuntu "Software & Updates" System application. I interrupted the upgrade and tried this to roll it back.

After this I had a similar problem with ssl but it went away eventually.

closed as off-topic by Jeff Schaller, Stephen Rauch, Satō Katsura, Michael Homer, Kusalananda Sep 2 '17 at 8:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Stephen Rauch, Satō Katsura, Michael Homer, Kusalananda
If this question can be reworded to fit the rules in the help center, please edit the question.

0

Ok, so it seems the source of the problem was that I had Qt linked libraries like libQt5Core.so.5 in /usr/local/lib. When I remove them everything worked again.
I've read that the package manager doesn't put any libraries there, so it was probably me who did a dumb mistake.

Not the answer you're looking for? Browse other questions tagged or ask your own question.