3

I am working on a raspberry pi box with ubuntu(15.10) installed. It has limited memory so I want to same as much as possible.

In memory usage report wicd/NetworkManager and subprocesses usage aprox 60MB RAM. Is there a way to setup networking without using that much ram?

My rpi is connected to LAN using Ethernet I don't need wireless support.

I tried setting up /etc/network/interface and disabling wicd/NetworkManager but unable to get eth0 up.

I have tried steps in how-to-access-network-without-networkmanager but unable to get it working.

5

I had problems with network manager on ubuntu , so i set up static networking. You can follow these steps and it will work ( i configured only wlan0 because i use wireless , you just need to skip the wireless related things in it)

Show your interfaces:

 $ ip a show

Note the default Ethernet and wifi interfaces:

It looks like our Ethernet port is eth0. Our WiFi radio is wlan0. Want to make this briefer?

$ ip a show | awk  '/^[0-9]: /{print $2}'

The output of this command will look something like this:

  lo:
  eth0:
  wlan0:

Your gateway IP address is found with:

route -n

It provides access to destination 0.0.0.0 (everything). In the below image it is 192.168.0.1, which is perfectly nominal.

route-n Let’s do a bit of easy configuration in our /etc/networking/interfaces file. The format of this file is not difficult to put together from the man page, but really, you should search for examples first. interfaces Plug in your Ethernet port.

Basically, we’re just adding DHCP entries for our interfaces. Above you’ll see a route to another network that appears when I get a DHCP lease on my Ethernet port. Next, add this:

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp
auto wlan0
iface wlan0 inet dhcp

Next, enable and start the networking service:

sudo update-rc.d networking enable



sudo /etc/init.d/networking start

Let’s make sure this works, by resetting the port with these commands:

sudo ifdown eth0
sudo ip a flush eth0

    sudo ifup eth0

This downs the interface, flushes the address assignment to it, and then brings it up. Test it out by pinging your gateway IP: ping 192.168.0.1. If you don’t get a response, your interface is not connected or your made a typo.

Let’s “do some WiFi” next! We want to make an /etc/wpa_supplicant.conf file. Consider mine:

network={
ssid="CenturyLink7851"
scan_ssid=1
key_mgmt=WPA-PSK
psk="4f-------------ac"
}

Now we can reset the WiFi interface and put this to work:

sudo ifdown wlan0



sudo ip a flush wlan0

    sudo ifup wlan0



sudo wpa_supplicant -Dnl80211 -c /root/wpa_supplicant.conf -iwlan0 -B



sudo dhclient wlan0

That should do it. Use a ping to find out, and do it explicitly from wlan0, so it gets it’s address first:

$ ip a show wlan0 | grep "inet"

Presumably dhclient updated your /etc/resolv.conf, so you can also do a:

ping -I 192.168.0.45 www.yahoo.com

you’re now running without NetworkManager!

  • Thanks for quick response. When I tried to setup my network by disabling wicd/networkmanger Ifconfig does give me only lo network adapter. – Hemant Jan 4 '16 at 9:08
  • no , you should run ip a show , or ifconfig before disabling network manager – Ijaz Ahmad Khan Jan 4 '16 at 9:30
  • Got it working :) Thanks alot for your help. I was using wrong name of Ethernet adapter. – Hemant Jan 5 '16 at 15:07
  • 1
    Ok , good , grt , welcome – Ijaz Ahmad Khan Jan 5 '16 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.