I've been struggling for the past two days to get my Bluetooth keyboard to work with my Raspberry Pi 2, with Kali 2.0 installed (I have gotten Adafruit's PiTFT software from http://adafruit-download.s3.amazonaws.com/adafruit_pitft_kernel_1.20150420-1.tar.gz, and have installed it, and it's helper script). I'm thinking this is a software issue, since my Bluetooth dongle is recognized with hcitool dev, and I can properly scan nearby Bluetooth devices with hcitool scan.

I followed an article, that said to install several things (to get the Bluetooth to work), one of which was bluez-utils. Apt returned an error, saying that bluez-utils was outdated, and bluez was a replacement for it. So I removed bluez-utils from the command, and installed bluez, python-gobject, and a few other needed packages. Then, I tried using bluez, to find that I got command not found from bash. So, I did a filesystem search with find /* | grep bluez to find that bluez's documentation was installed, but bluez wasn't. I then tried installing it from source, to find that it needed a ton of dependencies, and those dependencies needed tons of dependencies, etc., so I gave up on that route.

I would be fine installing bluez from source, if there is a simple and easy way to do it.

Any help with installing bluez would be appreciated.


The bluez package doesn't install a bluez binary, so it's perfectly normal that your shell can't find one; it installs the bluetoothd daemon and a number of different tools, bccmd, bluemoon, bluetoothctl, btmon, ciptool, gatttool, hciattach, hcitool, hex2hcd, l2ping, l2test, mpris-proxy, rctest, rfcomm and sdptool, along with manpages which explain how to use them.

To see what was installed, run dpkg -L bluez.

  • This was in part of what my issue was. I ended up installing it from source, and used bluetoothctl. – Flare Cat Jan 3 '16 at 19:43
  • I was wondering where bluez-simple-agent was, because an article I read used it, and it wasn't included in bluez. – Flare Cat Jan 3 '16 at 19:46

The best way to solve this (worked for me) is to reinstall the program. When uninstalling, completely uninstall it instead of normally. Then install it as you would normally.

Also, it might help to read the documentation that it installed!

  • I tried this twice, and it didn't work. I also tried uninstalling it with apt-get purge, and it still didn't work. I ended up installing it from source, from an article, and got it to work. – Flare Cat Jan 3 '16 at 19:41

I ended up following http://www.elinux.org/RPi_Bluetooth_LE, and it worked fine. Thanks for all of your help!

Also, I believe my issue was that bluez didn't install a binary called bluez, it installed other tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.