5

I use Awesome WM on Fedora 23. When I enter text in Firefox or gVim the mouse cursor stays visible. When entering text in Konsole or Dolphin, the cursor is hidden until I move it again.

The KDE behavior is much more what I want. How can I change this in GTK applications?

0
5

There is program called unclutter which hides mouse pointer while not in use. To install it on fedora (if haven't already):

dnf install unclutter

And then start it with -idle option to set number of seconds before pointer will be hidden, e.g.:

unclutter -idle 2 &

You may want to add above line to .xinitrc or similar startup file.

4
  • 1
    unclutter -keystroke should do (at least partially) what OP is asking for; hide mouse while typing – ZN13 Jan 1 '16 at 21:45
  • @ZN13 That sounds like a system wide option and not something that hinges on the particular toolkit used. I just tested it and it does not work with Firefox for instance. The manual page has a paragraph about this limitation and I fear that this -keystroke option does not change the behavior in Firefox. The timeout might be a viable option, though. – Martin Ueding Jan 1 '16 at 22:23
  • @MartinUeding unclutter -idle 2 works for me on firefox too, just tested. However It is possible that firefox has some built-in option (accessible via about:config) to turn such mouse behavior on/off, but I'm not aware of that. – jimmij Jan 1 '16 at 22:50
  • Sure, the timeout works in every case. Setting this in Firefox seems pointless as that does not help with other programs. – Martin Ueding Jan 1 '16 at 23:12
3

The keystroke option in unclutter does not work well. xbanish does what you demand: no timeout, it hides the cursor when a key is pressed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.