3

I installed ubuntu 15.10 (kernel 4.2.0-22-generic) on a brand new Asus UX303UA laptop. Almost everything works fine, but I have some trouble with suspending: When the laptop is plugged in (charging), suspend and resuming from suspend works just fine. Strangely, when it runs on battery, it does not properly resume from suspend, instead it just reboots. It does not make any difference whether I suspend from the menu, close the lid or run systemctl suspend from the command line.

Any suggestions on how to tackle down the issue are welcome. So far I could not find anything relevant in syslog etc.

Edit: Some answers to the comments:

  • The duration of the suspend state seems to make no difference, I tired between 20 seconds and several hours... always to same result.
  • If I suspend while to laptop is plugged-in, then unplug and then try resume, the problems is the same. Similarily, if I unplug, then suspend, then plugin in and then try to resume, the laptop will reboot. So it seems the the computer needs to be plugged-in during suspend AND resume.

EDIT2: Some more infos to my installation:

  • Running ubuntu in EFI-mode
  • no swap partition
  • main partition is encrypted
  • Taking a long shot here but, try changing power settings. – ZN13 Jan 1 '16 at 12:31
  • Have you tried suspending while plugged in, unplugging, and then resuming — and vice versa?  On battery, does it resume correctly if you try to resume a very short time (e.g., a minute) after suspending?  Please do not respond in comments; edit your question to make it clearer and more complete. – G-Man Jan 1 '16 at 12:51
  • I also have a UX303UA but I haven't yet installed Ubuntu on it. You say almost everything works, do the function keys for brightness & aeroplane mode and the ambient light sensor work out of the box? – freddybob Jan 19 '16 at 23:51
  • no, so far ambient light sensor & brigthness keys do not work out of the box (but there are workarounds). I'dont know about the airplane mode never used that – Raphael Roth Jan 20 '16 at 7:11
  • thanks Raphael, I'll give Ubuntu 15.10 a go on this device – freddybob Jan 20 '16 at 10:22
3

Here is an exactly same open issue on the bugzilla.kernel.org site: Reboot upon wake from suspend - ASUS Zenbook UX305CA

0

With the latest update (from kernel 4.2.0-22 to 4.2.0-23) suspend now finally works!

EDIT: With kernel 4.2.0-35, the problem appeared again

  • I just got the same problem after upgrading to 4.8.0-30 (I didn't have before)... pfff – vcarel Dec 12 '16 at 13:39
0

Adding "acpi_sleep=nonvs" seemed to solve this on ubuntu 16.04, but resume only works sometimes, and I'm not sure in which conditions.

I followed this old post: https://askubuntu.com/questions/24048/suspend-fails-reboot-on-resume-and-no-hibernate-option

Also tried updating to kernel 4.4.8 but it doesn't seem any better.

  • I'm running now ubuntu 16.04 and installed a newer kernel manually (I think it was 4.5 or even 4.6), the problem with suspend seems solved now – Raphael Roth Jun 29 '16 at 7:02
  • I'm running Ubuntu 16.04 and have tried kernel 4.4, 4.6, 4.7, with and without the parameter "acpi_sleep=nonvs" and it never works. – fgblomqvist Aug 5 '16 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.