2

So I'm trying to backup a folder with subfolders to another disk and it won't fit.

I used

rsync -aiv --delete /mysrc /mydest

There are no links (symlinks or hardlinks) of any sorts on the source.

I ran

du -d 1 -h

on the the source, 1 subfolder is around 195GB but after transferring it to the destination, it now occupies 260+GB according to the same command.

As such, I cannot fit 365GB source folder into the 450+GB (formatted size) disk.

Both drives are formatted as UFS. Any ideas on the huge discrepancy?

Thanks a lot :)

edit. I just tried copying another subfolder using

cp -av mysrc mydest/

to a new disk (320GB formatted as UFS). According to du, the folder occupies around 144GB on the source. But when I ran du on the destination, it uses around 165GB.

1 Answer 1

2

If any of the files are "sparse" (i.e. files with empty unallocated holes in them) then doing a logical copy using any sort of copy mechanism that reads and writes files then you could get this result. There is an option for copying sparse files using rsync (i.e. --sparse). Try using that option.

Another issues is possibly the underlying size of the configured blocksize on the destination file system. If they are not the same then you could have a situation as you have seen. In otherwords, suppose you have a blocksize setup on the destination disk as 8K...then any file sized from 0-8196 bytes uses one cluster. Thus copying files that are not even multiples of the blocksize may result in blocks at the end of each file that are allocated but not used. This could be a problem here if you have many many small files.

Those are my best educated guesses as to what you might be seeing.

1
  • thanks for the reply. The files are mostly video/music files. easily around 5+MB for the music files and 100+MB for the video files. I'll look into the "sparse" option. Thank you
    – mrjayviper
    Jan 1, 2016 at 4:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .