11

I just upgraded my MOBO and CPU on my PC, and now whenever I try and boot my debian install it hangs at [ OK ] Started Update UTMP about System Runlevel Changes. Is there an way I can boot into my old setup with my new hardware without having to completely reinstall?

Specs:

  • CPU = AMD Phenom II 965 3.4 Ghz x4 -> AMD FX 8350 4.0 Ghz x8

  • MOBO = ASUS M4A87TD EVO -> ASUS M5A99FX PRO

1

2 Answers 2

17

There is probably a problem with your video driver. I resolved it by following (modified) instructions at http://ubuntuforums.org/showthread.php?t=2072420:

  • Press Alt+F2 to switch to a new console
  • sudo apt-get purge xserver-xorg-video-intel then reboot
  • sudo apt-get install xserver-xorg-video-intel
  • nano /etc/X11/xorg.conf, remove any present code (if applicable) and enter the following:

    Section "Device" 
        Identifier "Card0"
        Driver "intel" 
        Option "AccelMethod" "sna" 
    EndSection
    
  • Save the file and reboot

3
  • Had same message on boot, fixed it only with the sudo apt-get install xserver-xorg-video-intel part (didn't have the intel xserver installed nor any xorg.conf file)
    – aesede
    Jul 18, 2016 at 20:55
  • It does happen in other situations too, I'm seeing it trying to make my Raspberry Pi do an autologin for some automated testing. I won't claim to understand it, but it doesn't always point to a video problem.
    – Alan Corey
    Sep 27, 2016 at 14:30
  • Thanks for these instructions! Fixed the problem with purge and install - didn't have to edit xorg.conf.
    – ty.
    Jan 11, 2017 at 6:46
2

Bas van dongen's answer pointed me in the right direction, although in my case it was the nvidia driver that was failing.

First run nvidia-installer --uninstall.

Then follow these instructions for reinstalling the nvidia driver on Jessie

  1. Add jessie-backports to your /etc/apt/sources.list, for example:

    # jessie-backports
    deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
    
  2. Install Linux headers for the kernel you are using.

    For example, if you are using the 3.16 Linux kernel in Debian Jessie:

    apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')
    

    Or if you are already using a Linux kernel from jessie-backports:

    apt-get install -t jessie-backports linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')
    
  3. Then we can install the package nvidia-driver.

    apt-get update
    apt-get install -t jessie-backports nvidia-driver
    
  4. Restart your system to enable the nouveau blacklist.

See this bug report for more information

1
  • I had a similar Nvidia Driver issue to this after apt dist-upgrade. I fixed this with aptitude install nvidia-driver-460 and made it remove whatever it "upgraded" to.
    – philn
    Jan 18 at 1:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.