1

i finished to install the Arch linuks with lvm on Luks and rebooted after configuring the GRUB.

when i boot to the USB GRUB i get: enter image description here

i have edited this page and fixed the UUID number to the sda1

Edit: i boot with the archiso and when im trying re re-generate :

# grub-mkconfig -o /mnt/boot/grub/grub.cfg

i get lots of warning all the same:

warning: failed to connect to lvmetad. falling back to internal scaninng . /run/lvm/lvmetad.socket: connect failed no such file or directory.

any ideas?

  • You need to show us your grub,cfg – fpmurphy Jan 1 '16 at 0:00
1

https://wiki.archlinux.org/index.php/Dm-crypt/Encrypting_an_entire_system#Configuring_the_boot_loader

Please read the Arch wiki section above.

Firstly, you will need to add the encrypt and lvm2 hook into mkinitcpio.conf, and then run:

mkinitcpio -p linux

Secondly, we need to let grub decrypt the disk in advance of the boot process.

Below I quoted the detail in the Arch wiki:

In order to unlock the encrypted root partition at boot, the following kernel parameters need to be set by the bootloader:

cryptdevice=UUID=device-UUID:lvm root=/dev/mapper/MyVol-root
The <device-UUID> refers to the UUID of /dev/sdaX

This is how it works: you will need to decrypt the disk first in kernel parameter so that you can boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.