2

while trying to build it (executing install.sh), manny, many compiler warnings/errors appear:

error: implicit declaration of function 'daemonize' [-Werror=implicit-function-declaration]
warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
etc...
etc...

I know the same problem has been fixed/worked around with other drivers, for instance here for rtl8188CU driver.

Is there any fix/workaround which can make the complilation work for the RTL8192SE?

Thanks.

(I don't want the pre-installed driver because it does not allow me to get in monitor mode)

EDIT: You can download the drivers ISO here (containing windows, OSX and Linux versions). I use kali-linux Sana (2.0), with kernel 4.0.0-kali1-amd64. gcc version is 4.9.2.

  • You might get a better response if you included a link to the driver source code that you are trying to build, and details of your OS and kernel version – steeldriver Dec 31 '15 at 14:56
1

Often the driver code for Linux you find at random sites (i.e., not in the vanilla kernel code, or some dedicated repo with kernel sources for a family of related devices) is way, way out of date with respect to the kernel sources you are trying to build against. Linux development moves ahead at breakneck speed, 24/7. No wonder the build fails.

Look for people working on this device (perhaps start with the names cited in the vanilla driver or perhaps its in-kernel documentation). There might be something in staging.

  • Well, the driver i downloaded from the official repository works as a charm but refuses to go in monitor mode, so i thought this would be the way to go...? – Magix Dec 31 '15 at 16:09
  • By the way, this is not a "random site", this is the wlan interface manufacturer's one :( – Magix Dec 31 '15 at 16:12
  • @MagixKiller, what official repository? For your distribution? Note that fooling around building your own drivers is not for the faint of heart/newbies... – vonbrand Dec 31 '15 at 16:12
  • Well, Kali repository I guess. It worked plug&play, so the driver has been download from somewhere hasn't it? – Magix Dec 31 '15 at 16:15
  • 1
    Wow. This question is clearly an XY question then... I apologise :( and will ask another on how I do the thing I want. Thank you – Magix Dec 31 '15 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.