30

I have VirtualBox instance of Centos 5. The screen size is quite small (800*600) and I'd like to increase it to 1280*1080. Under the Gnome preferences for "Screen Resolution" I only get the option for 600*800 or 640*480.

I've tried editing my xorg.conf (based on this tutorial http://paulsiu.wordpress.com/2008/09/08/creating-and-managing-centos-virtual-machine-under-virtualbox/) but it doesn't seem to have made a difference. Here is a snippet from the edited section:

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes   "1280x800"
    EndSubSection
EndSection

Does anyone know how to do this?

3
  • 1
    How much video memory have you allocated to the graphics card in VB? Have you installed guest additions? – Gilles 'SO- stop being evil' Nov 23 '11 at 23:42
  • According to the Device Manager it's the VirtualBox Graphics Adapter - looking into this now. EDIT - it looks like it may be an option under the Guest Additions (virtualbox.org/manual/ch04.html#idp11274368), so I'm looking into that now - thank you for the tip. – Aaron Newton Nov 23 '11 at 23:45
  • This seems to have solved my problem. For those looking for the ISO it is available here as VBoxGuestAdditions_4.1.6.iso - download.virtualbox.org/virtualbox/4.1.6. I mounted this using the VirtualBox Devices > CD/DVD > Choose DVD Disk File menu and ran "sh VboxLinuxAdditions.run" from the media/<nameofdisk> directory – Aaron Newton Nov 24 '11 at 1:31
24

A maximum resolution of 800x600 suggests that your X server inside the virtual machine is using the SVGA driver. SVGA is the highest resolution for which there is standard support; beyond that, you need a driver.

VirtualBox emulates a graphics adapter that is specific to VirtualBox, it does not emulate a previously existing hardware component like most other subsystems. The guest additions include a driver for that adapter. Insert the guest additions CD from the VirtualBox device menu, then run the installation program. Log out, restart the X server (send Ctrl+Alt+Backspace from the VirtualBox menu), and you should have a screen resolution that matches your VirtualBox window. If you find that you still need manual tweaking of your xorg.conf, the manual has some pointers.

There's a limit to how high you can get, due to the amount of memory you've allocated to the graphics adapter in the VirtualBox configuration. 8MB will give you up to 1600x1200 in 32 colors. Going beyond that is mostly useful if you use 3D.

2
  • Thank you - marked as the correct answer as installing the VirtualBox Guest additions seems to have solved my problem. See my note above if you don't have the installation CDs. – Aaron Newton Nov 24 '11 at 1:55
  • 1
    I just followed this answer to fix the same problem with CentOS 7. I had to install kernel headers before autorun.sh in the Guest Additions cd would work. The error message from autorun.sh gives the names of the packages to install with yum. After installing Guest Additions, I just restarted the VM, and the problem is magically fixed. – Michael Hoffmann Nov 30 '17 at 18:20
5

I had the same problems with different setup:

Host OS: Linux Mint 17 Cinnamon 64-bit Guest OS: Centos 6.6 Virtualbox: Oracle VM VirtualBox Manager 4.3.10_Ubuntu

Solution which worked for me:

  1. Install Virtualbox --> Devices, Insert Guest Additions CD image

    [root@centos6 ~]# cd /media/VBOXADDITIONS_4.3.10_93012/
    [root@centos6 ~]# ./VBoxLinuxAdditions.run
    
  2. get custom resolution string:

    [root@centos6 ~]$ cvt 1600 900
    # 1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
    
  3. set custom resolution string:

    [root@centos6 ~]$ xrandr
    Screen 0: minimum 64 x 64, current 1024 x 768, maximum 16384 x 16384
    VBOX0 connected 1024x768+0+0 0mm x 0mm
       1024x768       60.0*+   60.0*
       1600x1200      60.0 
       1440x1050      60.0 
       1280x960       60.0 
       800x600        60.0 
       640x480        60.0 
    
    [root@centos6 ~]$ xrandr --newmode "1600x900_60.00" 118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
    
    [root@centos6 ~]$ xrandr --addmode VBOX0 "1600x900_60.00"
    
  4. use normal system administration config dialog to change resolution to 1600 x 900 which was not available before.

1
  • in centos 6 - after restarting the guest additional size options appeared and were made available to use successfully without adding a custom resolution. – Ross Dec 31 '15 at 4:57
1

You need Virtual Box guest extensions.

In order to install them you first need the RPMForge repository added for yum, follow these instructions:

http://wiki.centos.org/AdditionalResources/Repositories/RPMForge#head-5aabf02717d5b6b12d47edbc5811404998926a1b

Then run this command in a terminal:

yum install dkms
0
1

My virtual machine suddenly no longer supported full-screen.

Eventually, the fix was easy: I had to update to the newest version of VirtualBox, then re-install the newest version of Guest Additions. After doing that then restarting my VM, the resolution was automatically the correct (full-screen) size.

0

In my case (virtualbox 5 + centos 7), all I did is install the "Guest additional cd image", then restart the vm, and make it full screen when start, it automatically take the biggest resolution.

I think u might forget to reboot or didn't full screen it via host + F.

0

on CentOS 7.5 on VirtualBox 5.2.22 the solution was:

  1. install VirtualBox Additions
  2. create a kernel module configuration file for the module "vboxvideo". Without the "modeset" parameter the module fails to load.

    echo "options vboxvideo modeset=1" > /etc/modprobe.d/vboxvideo.conf

  3. reboot
0

For Mac, although VirtualBox Additions are apparently available now, I was unable to find a way of installing them.

However, changing the resolution in the settings of the guest machine (in my case CentOS) solved the problem. There was no option to automatically find the screen resolution as others have suggested, but trial and error enabled me to find the best (almost perfect) fit. Although the boot and login screen will look reduced still, once logged in the full resolution will be apparent.

Not the answer you're looking for? Browse other questions tagged or ask your own question.