0

I need to install libvirt Vagrant plugin but it fails with the following error:

$ vagrant plugin install libvirt
The plugin(s) can't be installed due to the version conflicts below.
This means that the plugins depend on a library version that conflicts
with other plugins or Vagrant itself, creating an impossible situation
where Vagrant wouldn't be able to load the plugins.

You can fix the issue by either removing a conflicting plugin or
by contacting a plugin author to see if they can address the conflict.

Vagrant could not find compatible versions for gem "ffi":
In Gemfile:
  libvirt (>= 0) ruby depends on
    ffi (~> 0.6.3) ruby

  ffi (1.9.10)

I use only hostmanager plugin. The error remains even after removing this plugin so I guess it must conflict with Vagrant itself.

Is it possible to modify the Gemfile of libvirt plugin to depend on ffi 1.9.10? How would I do that?

I had no problems on Fedora 21.

Also I don't know Ruby whatsoever. I just need this running.

5

I found the solution for my problem.

  1. The plugin is called vagrant-libvirt NOT libvirt
  2. The installation of vagrant-libvirt fails too.

    I found this line in ~/.vagrant.d/gems/extensions/x86_64-linux/ruby-libvirt-0.6.0/mkmf.log:

    gcc: error: /usr/lib/rpm/redhat/redhat-hardened-cc1: No such file or directory

    The solution for this problem is easy: dnf install redhat-rpm-config-36-1.fc23.noarch.

After this, the installation completed successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.