2

I am using a lenovo thinkpad w520 running fedora 22 and gnome 3. This particular laptop has both an integrated (Intel HD Graphics 3000) and discrete graphics (NVIDIA Quadro 1000M) card. When I'm in Linux, I only ever use the integrated graphics card because support for the NVIDIA card isn't awesome without installing proprietary drivers.

For the most part, this works well, except that the screen is always on 100% brightness. Turning down the brightness with either the keyboard controls or in the Gnome pane has no effect.

I did some poking and discovered that in the /sys/class/backlight directory there are two entries: intel_backlight and nv_backlight. I tried changing the brightness in the Gnome pane and watched the intel_backlight/brightness and nv_backlight/brightness files. The former does not change but the latter does. If I manually change the former, the true brightness actually does update.

So I guess I need to figure out how to tell gnome to use the intel_backlight device rather than the nv_backlight device. How would I go about doing this?

OS info: 4.2.8-200.fc22.x86_64
Using grub2.

  • I'm on a Dell XPS 15 w. HD graphics 2000 + nvidia optimus and it works OOTB. Your device must be quite different. Can you disable nvidia gpu via bios ? That would prolly be the easiest way to solve this... Else, see the answers here – don_crissti Dec 28 '15 at 18:37
  • @don_crissti i don't want to disable optimus because i use it when i'm booted into windows. i'll try the grub fixes, though. thank you for that link. – Woodrow Barlow Dec 28 '15 at 19:30
  • same issue on optimus-enabled laptop and fedora 28: csd-backlight-helper updates nv_backlight instead of intel_backlight – Alec Istomin Aug 12 '18 at 6:21
1

Create the following config for X11 following Archlinux wiki to force optimus hardware to use intel_backlight instead of nv_backlight:

# cat /etc/X11/xorg.conf.d/20-backlight.conf
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
EndSection

Note that in my fedora 28 this is the only X11 config snippet, the rest is likely detected automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.