0

I'm trying to install postresql93 but I have a problem with package dependencies

Problem: postgresql93-9.3.5-2.1.14.x86_64 requires systemd, but this requirement cannot be provided  uninstallable providers: systemd-210-25.5.4.i586[openSUSE:13.2] 
               systemd-210-25.5.4.x86_64[openSUSE:13.2] 
Solution 1:   
Following actions will be done:   
    deinstallation of sysvinit-2.86-215.1.x86_64
    deinstallation of ivman-0.6.14-201.31.1.x86_64
    deinstallation of libgphoto2-2.4.3-3.25.73.x86_64
    deinstallation of libzypp-9.16.4-0.5.2.x86_64
    deinstallation of xorg-x11-server-7.4-27.70.76.1.x86_64
    deinstallation of xorg-x11-driver-video-radeonhd-1.3.0_20100512_80ba041-1.8.55.x86_64
    deinstallation of libgphoto2-lang-2.4.3-3.25.73.x86_64
    deinstallation of yast2-ncurses-pkg-2.17.20-0.5.1.x86_64
    deinstallation of yast2-pkg-bindings-2.17.58-0.5.1.x86_64
    deinstallation of zypper-1.6.178-0.5.3.x86_64
    deinstallation of yast2-2.17.121.1-0.5.1.x86_64
    deinstallation of yast2-packager-2.17.98-0.5.73.x86_64
    deinstallation of yast2-bootloader-2.17.86-0.5.20.x86_64
    deinstallation of yast2-online-update-2.17.21-0.1.89.noarch
    deinstallation of suseRegister-1.4-1.26.5.1.noarch
    deinstallation of yast2-registration-2.17.35.4-0.5.1.noarch
    deinstallation of yast2-wagon-2.17.32.4-0.5.1.noarch
    deinstallation of yast2-add-on-2.17.28-0.5.95.noarch
    deinstallation of yast2-add-on-creator-2.17.15-0.5.93.noarch
    deinstallation of yast2-audit-laf-2.17.10-0.2.18.noarch
    deinstallation of yast2-autofs-2.17.1-0.1.61.noarch
    deinstallation of yast2-boot-server-2.14.0-276.38.noarch
    deinstallation of yast2-ca-management-2.17.23-0.5.25.noarch
    deinstallation of yast2-dhcp-server-2.17.6-0.4.2.21.noarch
    deinstallation of yast2-dirinstall-2.17.4-0.5.238.noarch
    deinstallation of yast2-firewall-2.17.11-0.5.92.noarch
    deinstallation of yast2-inetd-2.17.3-1.53.noarch
    deinstallation of yast2-instserver-2.17.6-0.2.1.1.noarch
    deinstallation of yast2-irda-2.17.3-0.1.85.noarch
    deinstallation of yast2-iscsi-client-2.17.34-0.5.1.noarch
    deinstallation of yast2-iscsi-server-2.17.10-0.7.3.noarch
    deinstallation of yast2-isns-2.17.2-0.2.2.noarch
    deinstallation of yast2-metapackage-handler-0.8.7-1.34.noarch
    deinstallation of yast2-nis-server-2.17.2-1.53.noarch
    deinstallation of yast2-ntp-client-2.17.14-1.10.14.noarch
    deinstallation of yast2-pam-2.17.3-0.5.211.noarch
    deinstallation of yast2-power-management-2.17.7-0.1.84.noarch
    deinstallation of yast2-repair-2.17.11-0.5.109.noarch
    deinstallation of yast2-runlevel-2.17.9-0.7.3.noarch
    deinstallation of yast2-samba-client-2.17.21-0.5.186.noarch
    deinstallation of yast2-security-2.17.15-0.5.214.noarch
    deinstallation of yast2-slp-server-2.17.4-0.2.48.noarch
    deinstallation of yast2-sshd-2.17.2-1.21.noarch
    deinstallation of yast2-sudo-2.17.3-1.53.noarch
    deinstallation of yast2-support-2.17.19-2.1.59.noarch
    deinstallation of yast2-sysconfig-2.17.0-1.38.noarch
    deinstallation of yast2-fingerprint-reader-2.17.7-0.1.201.x86_64
    deinstallation of yast2-mouse-2.16.1-19.38.x86_64
    deinstallation of yast2-nis-client-2.17.8-0.1.1.x86_64
    deinstallation of yast2-printer-2.17.63-0.2.43.x86_64
    deinstallation of yast2-profile-manager-2.17.2-0.7.5.x86_64
    deinstallation of yast2-squid-2.17.11-0.3.46.x86_64
    deinstallation of yast2-tune-2.17.7-1.28.x86_64
    deinstallation of yast2-update-2.17.23-0.5.40.x86_64
    deinstallation of yast2-users-2.17.51-0.5.166.x86_64
    deinstallation of yast2-backup-2.17.14-0.5.1.noarch
    deinstallation of yast2-ftp-server-2.17.9-0.5.2.noarch
    deinstallation of yast2-http-server-2.17.15-0.5.2.noarch
    deinstallation of yast2-kdump-2.17.22-0.4.3.1.x86_64
    deinstallation of yast2-kerberos-client-2.17.15-0.5.1.noarch
    deinstallation of yast2-ldap-2.17.7-0.5.1.x86_64
    deinstallation of yast2-ldap-client-2.17.35-0.5.2.noarch
    deinstallation of yast2-ldap-server-2.17.44-0.5.1.x86_64
    deinstallation of yast2-mail-2.17.6-0.13.1.noarch
    deinstallation of yast2-nfs-server-2.17.8-0.2.1.noarch
    deinstallation of yast2-restore-2.17.7-0.5.1.noarch
    deinstallation of yast2-samba-server-2.17.14-0.5.1.noarch
    deinstallation of yast2-storage-2.17.127.2-0.5.3.x86_64
    deinstallation of yast2-tftp-server-2.17.2-0.2.3.1.noarch
    deinstallation of yast2-vm-2.17.10-0.5.42.x86_64
    deinstallation of yast2-network-2.17.182.12-0.5.11.x86_64
    deinstallation of yast2-nfs-client-2.17.14-0.5.1.noarch
    deinstallation of yast2-registration-branding-SLE-2.17.35.4-0.5.1.noarch
    deinstallation of yast2-online-update-frontend-2.17.21-0.1.89.noarch
 Solution 2: do not install postgresql93-9.3.5-2.1.14.x86_64
 Solution 3: do not install postgresql93-9.3.5-2.1.14.x86_64
 Solution 4: break postgresql93-9.3.5-2.1.14.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/4/c] (c): 

What are the recommended steps to attempt here? If I go with 1 will all the packages be removed?

1

It seems that you're mixing SLES 11 with openSUSE 13.2 RPM's. "systemd" is not available in SLES 11, so trying to install an RPM which has a mandatory dependency to systemd will fail.

UPDATE:

The suggested way to solve this problem would be to get/use a license for SLES 11. After registering your system with that licence you could automatically configure online update repositories that are maintained by SUSE. These repositories contain a Postgresql version which should perfectly fit.

There's also an repository in the open Build Service (for SLES 11 SP3), but it's not maintained anymore, I think. At least the build is broken.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.