1

I made two Virtualbox virtual machines, CentOS 7 latest iso. I gave them each 2 network interfaces, one NAT and one "Internal network" in order to get them to talk to each other and have Internet access. I set manual IP addresses for each:

NAT interfaces: VM1: 10.0.2.15/24 - VM2: 10.0.2.16/24 Internal Network interfaces: VM1: 10.0.2.1/24 VM2 10.0.2.2/24

My problem is, my SSH port forwarding rules don't work unless I disable the "internal network" interfaces. Once I do, port forwarding starts working again.

How could I fix this? My goals are to have the 2 VMs able to communicate with each other and with Internet access.

2

try

 NAT interfaces: VM1: 10.0.2.15/24 - VM2: 10.0.2.16/24 
 Internal Network interfaces: VM1: 10.0.3.1/24 VM2 10.0.3.2/24

You will have trouble using same network on differents interfaces.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.