1

I recently switched to Linux from Mac, and I am having a hard time getting the wireless to work on Fedora 23. I read many threads regarding this problem but none of them worked for me. I tried things like yum install kmod-wl returns a message no package akmod-kl available, and I tried manually installing package from the folllowing link: https://www.rpmfind.net/linux/rpm2html/search.php?query=broadcom-wl for whatever reason, whenever I tried to install one of listed packages. The system returns a message of

the installation of common files for broadcom 802.11 STA driver failed.

  • You have to install the firmware files/packages first. I am more used to Debian, someone more experienced with Fedora will certainly help you. – Rui F Ribeiro Dec 27 '15 at 20:19
2

I had this issue around an year back (with Feodra 21) and ended up writing a blog post about it: http://www.gautham.net/2015/01/broadcom-wl-driver-working-fedora-21-akmod-wl-bcm4312.html

In a nutshell though you seem to have not enabled the RPM Fusion repositories, which are required for the akmods package and the akmod-wl package. See http://rpmfusion.org/ for more information.

  • 1
    Excellent URL. I am however obliged to tell you people seem to value more elaborate posts, and there is a policy of encouraging people to paste relevant parts of external links to the answer itself. With time, you will notice it too. – Rui F Ribeiro Dec 27 '15 at 20:39
  • 1
    Point noted. In this situation, since the OP did not mention enabling RPM Fusion, I assumed that it was the reason why (a)kmod-wl wasn't able to be installed. If I had written instructions to enable RPM Fusion, that might have quickly been outdated but its website would forever have the latest how-to. – wingedrhino Dec 27 '15 at 20:50
  • @mahtuag, hi, I followed your instructions(sort of) and installed RPM fusion(both free and non-free). After that, sudo yum install kernel-devel akmod-wl and sudo systemctl restart NetworkManager on the terminal, but the wireless is still not working.. – please rekt me Dec 27 '15 at 21:04
  • Did you do sudo akmods ? That should build your driver. If the output indicates no errors, you should restart NetworkManager again and see if WiFi is enabled now. – wingedrhino Dec 27 '15 at 21:08
  • I tried that. and it gives the same output Parag Bansal, who commented on your blog, was having. – please rekt me Dec 27 '15 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.