5

Fedora 23 tend to freeze with the nouveau display drivers with my Geforce GT240. I already solved this issue on Ubuntu by installing the proprietary drivers with the Driver Manager. Is there something like that by Fedora 23?

I didn't find any application related to drivers. :S I have found some CLI tutorials about how to do this manually, but I am not sure whether they are reliable. Some of them are talking about xorg-server version change from 1.17 to 1.18 and that nvidia won't support 1.18 until it is stable. It became stable at december 8. Now the tutorials I found are from august, so I cannot imagine how they made Fedora 23 + xorg-server 1.18 rc work with the old nvidia drivers, which does not support the new version of the xorg-server... Any idea about where to find something reliable in the topic or how to install the 3.40.x nvidia proprietary drivers?

  • You have to either wait for Nvidia to release a stable driver and for rpmfusion to package the driver(s) rpmfusion.org or manually install it yourself. This tutorial - if-not-true-then-false.com/2015/fedora-nvidia-guide . Without knowing what card you have and what , if anything you tried, it is difficult to impossible to give better advice. – Panther Dec 26 '15 at 13:52
3

a.) working but not recommended solution

I managed to install the drivers manually following this guide:

The problem with this approach, that (according to some forums and my experience) the nvidia driver overrides some other libs as well, and a dnf update can override those libs, which will result a VERY unstable system. Not to mention that accidentally installing nvidia drivers from RPM fusion will totally kill the system beyond repair. (I did not manage to boot in that case, not even in text mode.)

So this approach works only if you don't plan to update the system, or you are very careful about what you update.

b.) recommended solution

I managed to install the driver from RPM fusion.

First you need to register the free and non-free repos. http://rpmfusion.org/Configuration

By the driver installation the first 6 try did not work by me, I got an error message "something went wrong" and a button with "logout" label after the reboot. No need to worry in that case, it is easy to uninstall the package with ctrl+alt+f2 and dnf remove akmod-nvidia. After that a reboot restores the system to the nouveau driver, which freezes, but works for 1-30 mins per session.

Be aware that not always akmod-nvidia is the good driver for your card. In my case I needed akmod-nvidia-340xx. You can find which driver you need here: ftp://download.nvidia.com/XFree86/Linux-x86_64/352.63/README/supportedchips.html

My install script was:

dnf update
dnf install akmod-nvidia-340xx.x86_64 kernel-devel gcc gcc-c++ vdpauinfo
libva-vdpau-driver libva-utils xorg-x11-drv-nvidia-340xx-libs.i686
dracut -f /boot/initramfs-$(uname -r).img $(uname -r)
reboot

I am not sure why this worked. I mean I tried something similar 6 times, but it did work only for the 7th try. I consulted with the RPM fusion guys, maybe they fixed the repo meanwhile, or I did something better which I am not aware of.

According to some forums you need the 32 bit binaries of the xorg-x11-drv-nvidia-libs and other libs, because Gnome 3 depends on them. I am not certain about that, but it worked to me.

notes:

I installed other 32 bit binaries after I verified that this driver install works:

sudo dnf -y install \
  alsa-lib.i686 \
  alsa-plugins-oss.i686 \
  alsa-plugins-pulseaudio.i686 \
  alsa-plugins-pulseaudio.i686 \
  arts.i686 \
  audiofile.i686 \
  bzip2-libs.i686 \
  cairo.i686 \
  cdk.i686 \
  compat-expat1.i686 \
  compat-libstdc++-33.i686 \
  cyrus-sasl-lib.i686 \
  dbus-libs.i686 \
  esound-libs.i686 \
  fltk.i686 \
  freeglut.i686 \
  glibc.i686 \
  gtk2.i686 \
  imlib.i686 \
  lcms-libs.i686 \
  lesstif.i686 \
  libacl.i686 \
  libao.i686 \
  libattr.i686 \
  libcap.i686 \
  libdrm.i686 \
  libexif.i686 \
  libgnomecanvas.i686 \
  libICE.i686 \
  libieee1284.i686 \
  libsigc++20.i686 \
  libSM.i686 \
  libtool-ltdl.i686 \
  libusb.i686 \
  libwmf-lite.i686 \
  libwmf.i686 \
  libX11.i686 \
  libXau.i686 \
  libXaw.i686 \
  libXcomposite.i686 \
  libXdamage.i686 \
  libXdmcp.i686 \
  libXext.i686 \
  libXfixes.i686 \
  libxkbfile.i686 \
  libxml2.i686 \
  libXmu.i686 \
  libXp.i686 \
  libXpm.i686 \
  libXScrnSaver.i686 \
  libXScrnSaver.i686 \
  libxslt.i686 \
  libXt.i686 \
  libXtst.i686 \
  libXv.i686 \
  libXv.i686 \
  libXxf86vm.i686 \
  lzo.i686 \
  mesa-libGL.i686 \
  mesa-libGLU.i686 \
  nas-libs.i686 \
  nspluginwrapper.i686 \
  openal-soft.i686 \
  openldap.i686 \
  pam.i686 \
  popt.i686 \
  pulseaudio-libs-glib2.i686 \
  pulseaudio-libs.i686 \
  pulseaudio-libs.i686 \
  qt-x11.i686 \
  qt.i686 \
  redhat-lsb.i686 \
  sane-backends-libs.i686 \
  SDL.i686 \
  svgalib.i686 \
  unixODBC.i686 \
  zlib.i686

These can come handy if you want to run 32 bit applications, for example old games. https://gist.github.com/tomekwi/0e0eff870cf9b689379d

Update:

My first install was for Geforce GT 240. Now I changed video card to Geforce GTX 750 Ti. Before changing the video card I removed the driver of the old card with dnf remove akmod-nvidia-340xx xorg-x11-drv-nvidia-340xx-libs.i686 and installed the new driver with dnf install akmod-nvidia xorg-x11-drv-nvidia-libs.i686. After that I turned off the computer, changed the card and restarted the system. Everything is working fine since then.

2

Use the driver from rpmfusion

http://rpmfusion.org

See http://rpmfusion.org/Howto/nVidia#Latest.2BAC8-Beta_driver

Or if you want to grab it from the latest fedora stable release:

yum --releasever=23 install akmod-nvidia

yum install "kernel-devel-uname-r == $(uname -r)"

yum update -y

If you are running Fedora 23, you dnf rather then yum

Or if you want to grab it from the latest fedora stable release:

dnf install akmod-nvidia
dnf install "kernel-devel-uname-r == $(uname -r)"
dnf update -y

And then reboot.

Note: Not all cards are supported yet, see nvidia compatibility list

ftp://download.nvidia.com/XFree86/Linux-x86_64/352.63/README/supportedchips.html

  • "No package akmod-nvidia available. Error: Unable to find a match." yum didnt find it either – inf3rno Dec 26 '15 at 15:53
  • Added rpmfusion with this: rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm, but still does not find the driver. – inf3rno Dec 26 '15 at 16:54
  • Hmm I checked Fedora 23 could not add the free repo, but it was able to add the non-free repo, which contained the akmod-nvidia package. So it appears to be ok now. I'll try to restart. Anything about how to check which driver is on? – inf3rno Dec 26 '15 at 17:15
  • I restarted, or at least I tried to, but the system collapsed after restart. I can use only the command line. I tried to start the clean install from grub with similar results. So this akmod-nvidia is not compatible with fedora 23. I'll install ubuntu instead, I didn't like the DE, but at least it was stable with the nvidia proprietary drivers. Thanks for your help! – inf3rno Dec 26 '15 at 17:30
  • So run Fedora 22 until a working driver is available for 23, or use the open source driver (nouveau) – Panther Dec 26 '15 at 18:32
1

Here's what you do, and it ain't more complicated than this.

su -c 'dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

That is the official way to add the rpmfusion repositories, and then:

dnf install akmod-nvidia "kernel-devel-uname-r == $(uname -r)"
dnf update -y

Done! This is the official way to install these drivers

Then because I'm nice like that, here is my complete uninstall/reinstall command, in case the driver ever goes kaput (and it will, it will!, fear the kernel updates!)

sudo dnf remove xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs akmod-nvidia kmod-nvidia* && dnf install akmod-nvidia kmod-nvidia

(Please be noted this updates your /etc/X11/xorg.conf.d/99-nvidia.conf file, but since DNF is also nice, it creates a backup of the original, so if you have a custom config file remember that)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.