So my parents offered my a Laptop, a quite good one judging by my other computers (for example my Desktop is still stuck on CDQ), and it is always sort of rude to return a gift in any situation, but it has serious trouble with drivers.

The laptop is an Asus GL552V, which has fairly standard components:

  • Intel 6700HQ APU
  • Nvidia 960M
  • Intel 7265 Wireless
  • Atheros (or Realtek, not sure now) ethernet
  • A Samsung SSD

Basically nothing fancy or from a brand known to have serious driver issues (such as Broadcom). The problem is that Skylake only has proper kernel support from 4.3 on (4.2 is experimental and had to be toggled), besides one or other little details like the touchpad not working (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1520519), and the fan being always at full speed.

Im an Arch user, and simply thought "I'll have to use dev versions for a while, but it will work". Note that out-of-curiosity I booted several distributions, such as a daily Ubuntu 16.04 snapshot, but none booted, not even after disabling modeset on the nouveau driver and enabling skylake support.

So I installed Arch with the default 4.2.5 kernel, bumblebee, mesa 11.1, and Nvidia blob (guess I had no choice). With i915.preliminary_hw_support=1 it works, not ideal but at least manages to boot.

Tried to install both Gnome, KDE and XFCE.

From GDM only Gnome on Wayland works, Gnome on Xorg or XFCE and the computer just frezes after logging in (cant even get past the GDM backgroud).

SDDM already worked (it works no longer for some reason), and when it did, so did Plasma.

LightDM doesn't work at all (just freezes the computer). Also any of the previous combinations eventually hangs even Wayland Gnome or Plasma.

The logs say nothing, when the computer freezes it isn't some SW error, its probably with the HW.

Kernel 4.3 from the testing repo just halts on boot, and the same goes for mainline 4.4rc6 (can't get past Triggering uevents) and have no idea on how to debug it. Yet there are more people with trouble booting newer kernels on this APU (https://bugzilla.kernel.org/show_bug.cgi?id=109081)

I've read somewhere that most of my problems (GPU, Touchpad, maybe fan speed control) is fixed on 4.4, but being unable to boot it I can't even test.

I'm undecided, I'll not leave such an expensive laptop on a corner till some day (maybe never) it has a solid support, but would prefer to avoid refunding it. What options do I have? What can I try? Where can I look for useful debug info?

Right now I'm not really tied into any particular distro, anything that gives some hope is good.

  • 1
    how did you install arch? in uefi mode? have you enabled fastboot? i would think you'd need to do that. and gnome sucks (my opinion, of course) and always crashes anything! ive been using enlightenment for a few years now and i like it very well. its wayland support rocks. but if you're using the nvidia blob and wayland.... how? – mikeserv Dec 26 '15 at 3:39
  • @mikeserv I installed it in UEFI, fastboot off (will try to enable). I find gnome awesome once the user gets used to it (and quite stable in my other computers), englightnment feels weird to me but I can try :p The wayland session its running on the Intel card, not on the Nvidia one. – SOMN Dec 26 '15 at 3:53
  • I've never heard such compatibility issues with a new box; it does look like a highly Windows specific build. Do you want to get stuff done or have a pretty box (for some definition of pretty)?. You can do far better, hit the same price/performance and skip the compatibility problems. I know what I'd do. – msw Dec 26 '15 at 4:48
  • oh. well, then just do wayland w/ nouveau and you're golden. – mikeserv Dec 26 '15 at 4:52
  • @msw, Judging by the hw, I doesn't seem like one. Only piece of unknown HW is the touchpad. And actually no, where I live there this is one of the best price/performance offers right now for skylake. There are haswell/braodwell, and those have better compatibility (likely) but there's no warranty on that. – SOMN Dec 26 '15 at 4:53

The drivers start to appear in newer kernels. Here is the problem: https://bugzilla.kernel.org/show_bug.cgi?id=109081

In case anyone wants to buy this laptop to use with Linux, wait for that bug to be fixed before doing so.

Answering to the question: It would be a good idea to return the laptop if you had the same situation. I'll keep it for at least a week or two to provide any information the developers need, after it if the problem gets solved (which I hope it will get) I'll keep the laptop.


I have a GL552VW-CN108T (similar to yours without an SSD) and was able to boot from and install from a Linux Mint 17.3.

The touchpad is not working (fortunately so my "resting" thumbs won't move the cursor), but the graphics works out of the box.

The only thing that confused me initially is that I couldn't boot from SD-card. I had to put the SD in an external single USB reader for that to work. The internal SD card reader would not work, nor would a multi-card reader that I had successfully used on ASUS PC motherboards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.