2

I am installing Debian 8.2 Jessie in a Intel PC through a USB stick

I completed the installation in different ways today, but at the end of each of them,

I still am without an internet connection, I cannot even do apt-get update

I am reading here that it might be due wpa/wpe router settings

At the moment I am not sure if this means that it cannot connect with ssid and password details, and I have to find a way to somehow make the connection

I can make screenshots to the installation process with my phone

I have another debian 8.2 jessie running through virtualbox on a osx host (btw I installed virtualbox on the Intel PC with the exported osx debian machine and absolutely everything worked fine, including letsencrypt https and FTPS implicit, using noip domain)

What should I do?


# lsb_release -a:

No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.2 (jessie)
Release:    8.2
Codename:   jessie

# uname -a:

Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u3 (2015-08-04) x86_64 GNU/Linux
  • What type of connection to your house router are you trying to make, for example wifi? or ethernet (plugging in cable to computer directly)? Are you on the gnome desktop or is this problem where you are stuck during installation? – clarity123 Dec 24 '15 at 23:18
  • sounds like you are still within the setup. Have you gotten past selecting your language, selecting your location yet? – clarity123 Dec 25 '15 at 1:35
  • oh. In that case can you run the commands lsb_release -a and uname -a and update the question to include the outputs of these commands, to get more clues to help you. – clarity123 Dec 25 '15 at 1:45
  • Let us continue this discussion in chat. – clarity123 Dec 25 '15 at 2:49
  • A couple of questions: 1. you sure you have wireless card installed? 2. if yes, are you sure no any damaged to the wireless card? Just as what the above suggested, use cable connection first. Or use bootable usb with other os installed (mint?) ,boot it and test the wifi setting. – user148822 Dec 25 '15 at 10:23
1

Wifi from the command line is a pain unless you got wpasupplicant or network manager installed.

In your shoes I would hook up the computer with a cable and set everything up using that. Then when you have a graphical user interface (assuming you will set that up) I would activate the wifi.

The alternative, getting help here with setting up your wifi requires too much of information from you that is not provided in the question and us having to ask for it and you editing the question again. This is not really the function of StackExchange, here you ask a well written question and we provide an answer based on that well written question that contains all the information that we need to answer. If you prefer to use the command line to set up your wifi then I would suggest you seek assistance from the IRC community of debian, they are usually very helpful

| improve this answer | |
0

Debian Wiki on Wifi

Debian Docs for Networking

I've heard that advice myself many times, but meanwhile i understand it wasn't an insult. => RTFM!

EDIT

I think, you have the choice between 2 ways of solving that:

  1. you can just configure your networking like here - that way, you have at least a temporal connection to download the tools you want (e.g. network manager, resolvconf). If you've set up your connection and still can't access the internet, but ping 8.8.8.8 works, then have a look at this. That way you can also configure your network to work every time.

  2. You can, as @ojs said, download the neccessary tools while being connected with an ethernet cable and configure your networking from there. That should work with less pain than the first variant.

| improve this answer | |
  • then what exact method (network manager, legacy, etc.) are you're trying and where exactly do you have problems? – toogley Dec 25 '15 at 1:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.