1

I want to install VLC Media Player on Red Hat Enterprise Linux 7.2. My system is subscribed to the Red Hat Network.

I am following these steps and have run into dependency issues.

enter image description here

I downloaded and built the two missing dependencies from source however I am still getting the same errors when I run yum install vlc.

enter image description here

5
  • Did you build and install source RPMs, or just source? SRPMs would result in RPMs that yum would know about; plain source would not.
    – Jeff Schaller
    Commented Dec 24, 2015 at 18:54
  • Just source for the last two Commented Dec 24, 2015 at 19:04
  • Then you'll have to tell yum to ignore dependencies (since the dependencies are installed, just not with RPM)
    – Jeff Schaller
    Commented Dec 25, 2015 at 2:57
  • Correction -- looks like you have to get the RPM files and install the with rpm ... --no-deps. Yum doesn't ignore dependencies.
    – Jeff Schaller
    Commented Dec 25, 2015 at 3:32
  • Could you copy the text instead of images?
    – Braiam
    Commented Dec 25, 2015 at 18:35

2 Answers 2

2

I was able to install VLC by setting notify_only=0 in /etc/yum/pluginconf.d/search-disabled-repos.conf.

enter image description here

During the installation more repos were enabled and checked for dependencies which resolved the issue.

0

This worked for me:

I had to enable these repos to get it done.

# subscription-manager repos --enable=rhel-7-server-rpms 
# subscription-manager repos --enable=rhel-7-server-optional-rpms

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .