4

I am trying to install CentOS-6 on an eMMC drive. Since the supported 2.6.xx kernel from CentOS-6 doesn't support mmc, I compiled a newer kernel (4.2.6) which has updated mmc drivers. I tried booting using this kernel, but I still don't see /dev/mmcblk0.

When the boot exits to a shell without finding /dev/mmcblk0, I see that mmc_core, mmc_block and sdhci_acpi modules are loaded. Does anyone know how to make this available during boot ?

The same procedure works fine with the FC22/23 which has a 4.2.x kernel. What am I missing here ? Thanks for any hint.

*** EDIT

Here is the dmesg output. http://pastebin.com/STq4LuwK

*** Correction

mmc_block module is NOT loaded. Only mmc_core and sdhci-acpi and sdhci

*** EDIT-1

Changing udev rules inside initrd image, I could load mmc_block, but that still doesn't solve the problem.

  • First of all: please attach a dmesg output – silvio Dec 24 '15 at 23:58
  • definitely, by Tuesday... no access to machine... happy holidays... – iamauser Dec 25 '15 at 0:09
  • @silvio dmesg output is added along with a correction... – iamauser Dec 28 '15 at 17:21
  • 1
    So, a kernel from Centos works, but your custom kernel did not ? Then you did not build the modules needed for your hard drive. See also google.com/… – Panther Dec 30 '15 at 22:50
  • @bodhi.zazen CentOS kernel-2.6.xxx does not work. Only FC22 onwards work. I am compiling latest mmc drivers with the same CONFIG_MMC_* as the FC22/23. That doesn't help. I must be missing some other module that is not obvious... – iamauser Dec 30 '15 at 23:22
1
  1. Different kernels might not use the same names for block devices. It is preferred that you add a label to your block device and look for it /dev/disk/by-label.

  2. If you suspect that some module, enabled in Fedora kernels, is missing from your kernel configuration, you can get Fedora's kernel configuration and start from there:

    zcat /proc/config.gz > config

1

As it turned out, for my particular system, a kernel config was missing. It was the LPSS support from Intel. CONFIG_X86_INTEL_LPSS which has the particular support for 80860F14 acpi peripheral and needed for my Samsung eMMC drive. After including this, mmc block and core drivers could see /dev/mmcblk0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.