1

Im Installing Debian on an Old 650Mhz and 200MB RAM Laptop. Without GUI I just need it to work. After the installation finishes it says Operating system not found.

I researched a bit and seems like GRUB needs to be configured. Since I have no idea how to do it, Can someone help with this?

I found this solution: The solution was to set the boot flag on the root partition. I have another netbook with a BIOS. That one doesn't matter whether the boot flag is set or not. It still boots.

But I have no idea what he is talking about.

Hopefully this is the right place to ask this, sorry if it is not.

EDIT:

So, my issue is something like this:

http://www.linuxquestions.org/questions/linux-newbie-8/there-is-no-menu-lst-in-my-ubuntu-boot-grub-folder-785767/page2.html

but instead of XP i need to load Arch Linux.

I have successfully installed it and configured it, but when i restart to boot it says no Operating system.

EDIT 2:

Seems like BIOS does not recognize the HDD. It says Primary master: NONE.

I will investigate this issue and report back if nothing changes. Seems like this is the problem.

  • IIRC that message (OS not found) is thrown by the bootstrap (the exact, correct term might differ) code, before the bootloader starts. So, yes, your bootloader needs to be installed then configured. I have but a dusty recollection of GRUB legacy (0.xy) and have given up GRUB2 for sys/extlinux. Are you familiar with «chrooting into a system from a LiveCD» ? – user86969 Dec 24 '15 at 10:54
  • @Nasha Not really, I know how to access the Shell via installation Disc, but i can create a LiveCD, can you just point me where and what to look at? – AlCode Dec 24 '15 at 11:08
2

You can boot your system with any live CD, Debian, Fedora, anything. Once you've started the live system, you'll have to chroot into your installed system. Let's assume /dev/sda is the live CD and /dev/sdb the disk your system is installed onto.

You'll have to determine what your boot and root partitions are. Let's assume /dev/sdb1 and /dev/sdb2 respectively. In a terminal, type the following instructions, as root:

mount /dev/sdb2 /mnt
mount /dev/sdb1 /mnt/boot
for DIR in dev dev/pts sys proc; do mount --bind /$DIR /mnt/$DIR; done
chroot /mnt /bin/bash

Now execute the instructions to manually install and configure Grub. On Debian systems, it mostly consists of

update-grub

You might want to reinstall and configure grub again instead:

aptitude reinstall grub
update-grub # This should be useless as run by aptitude

Note: if you don't have aptitude installed you can safely replace aptitude with apt-get in the above instructions.

Once you're done, unmount all previously mounted directories and reboot. Or, shorter:

sync
reboot

I cannot guarantee you that your system will actually start but that's how a manual grub install looks like on a Debian system. Replace of course sda and sdb with your actual disk devices. I have assumed you aren't using LVM, too.


Im Installing Debian on an Old 650Mhz and 200MB RAM machine.

EDIT: Further re-reading your initial post, I recalled that hard drives appeared not as /dev/sda on older systems but /dev/hda — does your machine have an IDE drive? So there might be circumstances your hard drive simply is not found by the installer. Or the BIOS...!

I haven't touched any really old system for... well, can't remember! So I have little idea how it turns out when you whack in a fairly recent distribution on hardware that's that old. I remember there was a transition period of time IDE and SATA drives appeared alike but it was a very short period. Maybe that's a hint. Or not.

Also, as a side note be sure to flag the partition that actually boots your system, i.e. the one that the boot loader is installed. That one is called the boot partition. Of course, if you installed the boot loader on the root partition, then that's the one you must flag as bootable, otherwise it's usually /boot, hence the name.

If you installed the boot loader on the hard drive (e.g. /dev/sda or /dev/hda, without the partition ID), I don't think you need to flag any partition at all... at least fro my experience with SATA drives and recent machines.

There are cases /boot and / are the same partition. However I believe however modern installers do generally prepare any minimal system with at least one distinct partition for the boot code/loader.

  • Thank you Nasha, I will try this when Im back home, will keep you posted about this! hopefully it will work. – AlCode Dec 24 '15 at 12:30
  • GRUB doesnt work again, I even installed Arch LInux from zero.. and still Operating system not found. – AlCode Dec 24 '15 at 22:56
  • That is really uncommon as installers generally don't fail like this. Troubleshooting a boot fail may require a good number of steps of trial and error, questions and answers so I'd recommend you used the forums of your distribution for that. These forums are far better suited than Stack Overflow for that kind of troubleshooting. When you' re done you may very well get back here and post your fix as an answer to this question. – user86969 Dec 25 '15 at 8:51
  • So, i get /dev/sda as the name of the Drive, I even get the name and manufacturer of the HDD but in BIOS it can not be found. So I think it is a BIOS issue for now. I will test it when I come home and post updates. – AlCode Dec 28 '15 at 15:36
  • Right. But have you checked the master/slave selection jumpers? – user86969 Dec 28 '15 at 15:40
1

Boot from your installation media again; repeat installation but choose Lilo if possible instead of Grub at bootloader menu choice which may be found as last step of installation. Answer yes to any MBR installation questions.

Update: Partition it, but not recognize it after having installed, having written all the OS data? Sounds like one could boot manually using Grub to specify the disk, kernel parameters in Grub shell, but that is not intuitive; you may wish to research and do that.

Possibly easier solution: repeat Debian install and partition but leave some disk space not partitioned. Then try booting with some other Linux distro's such as Knoppix, Ubuntu as a live cdrom, usb until you find one that sees your Debian installation from its partition manager software. Recommend use of cfdisk instead of GParted for work with partitions. You could install this other distro into the unused space just to get it to create the proper Grub, MBR information.

  • I wouldn't recommend this unless strictly necessary. Best is to investigate and make grub load Linux first. Then only take desperate measures ;-) . – user86969 Dec 24 '15 at 11:27
  • @Kevin I did and the same result, I found out that in my BIOS Primary Master is set to NONE instead of HDD. Now this is strange, how can I see the HDD in my instalation and not when I boot? – AlCode Dec 28 '15 at 9:23
  • @Orom I remember having noticed that odd behaviour but didn't investigate. Sounds like you have indeed IDE drives. There are BIOSES that are touchy if you misconfigure the drive jumpers. Some drives require different jumper position if the drive (hence master) is alone or not. Hmmm... I guess that boot flag is indeed helping old BIOSES find the actual operating system boot code, see my updated response, just in case... – user86969 Dec 28 '15 at 9:42
  • @Nasha yes indeed, it is PATA since it an older drive. But Like i said it it very strange that Debian installation can partition it but BIOS doesn't see the drive. I will try removing it from the case and insert again. – AlCode Dec 28 '15 at 9:45
  • That's what jumpers are for in fact: they're for the BIOS, not the operating system. Missing one jumper may mislead the BIOS into showing no drive at all. Double check your driver jumpers and your IDE cable, it should help. – user86969 Dec 28 '15 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.