3

After updating from jessie to stretch this week I found my heaphone jack no longer outputs sound, though my built in speakers work just fine. The puzzling thing is that everything seems to be in order as far as I can tell. Pavucontrol shows output to the headphones device, but I don't hear anything. When I mute or unmute I can hear a pop in the headphones. The device is detected and activated when I plug in or remove headphones.

  • System Info: Lenovo Carbon X1, Debian Stretch, Card is HDA Intel PCH. my alsa-info.sh

  • What works: Headphone Detection, Pavucontrol, Builtin Speaker, I hear a pop when muting/unmuting.

  • I've tried the answers to this question. I've tried purging and reinstalling alsa and pulse audio.

Setting

[Element Speaker]
switch = on
volume = ignore

in /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf is a good idea but does not solve my problem.

  • I don't have this problem anymore. Some package update fixed it. – groceryheist Jun 12 '17 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.