1

When I try to configure Dovecot together with Exim, I get an error while restarting Exim:

Exim configuration error in line 63 of /etc/exim/exim.conf:
  main option "dovecot_login" unknown

What am I doing wrong?

1

It clearly states that in the exim.conf file, specifically line 63, the option dovecot_login doesn't exist. Double check that the version of exim supports that configuration item.

  • installed version is Exim version 4.72, it supports dovecot. – svu Dec 23 '15 at 20:48
  • Let me say it again, make sure it supports that configuration item. The one I highlighted which is dovecot_login – Digisec Dec 23 '15 at 20:53
  • sorry for the trouble i will check it... – svu Dec 23 '15 at 20:55
  • 1
    Just a friendly note, no one will be able to help you with barely an error message, all we get from it is that you used an unknown option. – Digisec Dec 23 '15 at 20:56
  • The directive seems to be misplaced. I suppose it should be in the section started with begin authenticators. – DaSourcerer Dec 29 '15 at 20:52
0

I'm assuming you were following the Debian HOWTO at https://wiki2.dovecot.org/HowTo/EximAndDovecotSASL, as I just did.

nowadays Debian uses exim4, and exim.conf doesn't exist, and would be ignored if it did.

the reason dovecot_login is unknown is because exim4 isn't prepared for it: the keywords begin authenticators must precede it in the configuration. if you're using the "split" configuration mode, as is typical for more complex installations, this could be accomplished by placing the file, perhaps named 05_dovecot, under /etc/exim4/conf.d/auth, which has the magic incantation in 00_exim4-config_header.

update-exim4.conf will process the files under conf.d/auth/ in lexical order, and it will ignore the pre-existing file "dovecot.conf" in that directory (because it ignores any file with a dot in it) and see 05_dovecot after 00_exim4-config_header.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.