On my pc-bsd box, I installed VirtualBox and trying to install FreeBSD 8.2 STABLE in 10GB space.

During installation, I selected all the default settings, it looks like this: Disk layout

But after this, I get this error:


How can I overcome it?

  • Is there a reason ad0s1c doesn't exist? Also, you might want to consider making individual virtual hard drives in VirtualBox instead of using partitions. – n0pe Nov 22 '11 at 12:48
  • @MaxMackie you misunderstand the BSD meaning of a "partition" - using linux nomenclature, it is all on a single disk partition. The disk partitions on BSD systems are called slices - all the above filesystems are on a single slice. – rozcietrzewiacz Nov 22 '11 at 13:09
  • 1
    @MaxMackie Yes, there is a reason why ad0s1c is not visible - it represents all the remaining part of the disk. Read how the BSD partitions, more often called disklabels are arranged. – rozcietrzewiacz Nov 22 '11 at 13:16
  • 1
    @hari How did you create the virtual disk - is it fixed size, or not? Also, did you properly set the virtual machine type to FreeBSD? – rozcietrzewiacz Nov 22 '11 at 13:18
  • 1
    I asked about the disk type because I thought it must be fixed for FreeBSD, but I see no evidence of this. Instead, what all such problem cases indicate is that you probably did not commit disklabel changes to disk before proceeding with the installation. Repeat that. – rozcietrzewiacz Nov 22 '11 at 23:45

Deleted that instance and tried another installation which worked fine. Sometimes its the only thing that can help you. Thanks for all the help. I am responding to this question so that it stays in record and someone else hitting this issue can get some help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.