Having the following software:

  • nginx web server
  • centos 7.1 OS
  • owncloud 8 Application
  • https Web Browsing Protocol

After resolving the issue of /config directory permissions, we reached this error:

Can't create or write into the data directory /usr/share/nginx/owncloud/data

I tried all of the following commands:

 chown -R nginx:nginx data
 chmod -R 750 data
# 2nd attempt
 chown -R apache:apache data
 chmod -R 750 data
# 3rd attempt
 chown -R nginx:nginx data
 chmod -R 777 data
# 4th attempt
 chown -R apache:apache data
 chmod -R 777 data

Nothing works -- same error message.

  • Does this require setsebool intervention (SELinux)?

  • Does permission modification require a restart of one of the services?

  • It is not a suitable owner -- nginx or apache -- knowing that http and www-data do not exist?

  • is your php_fpm running under webserver identity ?
    – dervishe
    Commented Dec 23, 2015 at 13:53
  • yes . i have php_fpm Commented Dec 24, 2015 at 2:32

1 Answer 1


Delete /etc/nginx/conf.d/default , since i have already /etc/nginx/conf.d/owncloud.conf

This step resolves my issue .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .