1

I installed apache on Debian:

sudo apt-get install apache2 apache2-utils

and ran

a2enmod cgi alias env

I want to use ScriptAlias command. However I get the message Command is missing.

I find this answer where suggestion was made that I should use

a2enmod mod_alias

When I use it I get the message

Module mod_alias does not exist

Do you have any suggestions how to solve this ?

I try to configure git with these instructions.

1
  • Shouldn't necessarily need to do this but did restart apache afterwards? – Panama Jack Dec 15 '15 at 21:49
5

Under debian, you can load the mod_alias module using:

$ sudo a2enmod alias

You should see two symbolic links alias.conf and alias.load in the folder /etc/apache2/mods-enabled.

After running this command, make sure that your current httpd configuration is correct using the following command:

$ sudo apache2ctl configtest

If no error message appears, restart the httpd server in order to activate this configuration change:

$ sudo service apache2 restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.