0

I tried to install Fedora 23 on dual-boot with an USB stick today. I followed this video tutorial: https://www.youtube.com/watch?v=gOP_FtP1e9U
I'm in UEFI mode, so I installed Fedora and everything worked perfectly until I had to reboot, then I got this error:

Reboot and Select proper Boot device or insert Boot Media in selected Boot Device and press a key.

I searched a lot for this error and it seems that a lot of people have problems with it. So I tried to resolve it by restarting my computer, going into the BIOS settings and changing the order of my boot device so my hard disk was in first place and my CD/DVD was in second place, I saved and restarted, it didn't work.

I also tried to put the CD/DVD in first place and it didn't work either, my BIOS version is 2.15.1227. I can only put my USB stick back and load fedora in live mode, so I tested the command to see in which mode I am and I am still in UEFI.

Here is my boot order:

BIOS boot order screenshot

I disabled the secure boot and the hibernation mode is on.

Even after changing the boot order, I still get the error; I don't know what to do.

1

I assume Fedora OS has been successfully installed according to your context of question, but it's unable to boot properly. I had this issue a while ago to dual boot between Windows 10 and Mint Linux too.

Try to set your HDD in highest priority in boot sequence as Fedora has been partitioned on your HDD - it has to look into HDD first to find the boot loader.

Also, try to look for 'secure boot' option on the BIOS settings and ensure to have it 'disabled' because UEFI mode mandates secure boot enabled in Windows 8 or later versions.

  • additional option to try: my BIOS

Above is my BIOS settings. I have 'Quiet Boot' set to Enabled.

Last option could be fixing your boot loader file by using 'boot repair', not sure if it's compatible with Fedora OS as I've only seen articles regarding Ubuntu based OS.

I really hope you have this issue resolved, but if not by above methods, you can search google about dual-boot in UEFI mode and ensure to have everything set up correctly.

  • Thanks for your reply, My HDD was already in highest priority so i just disabled the secure boot, I saved the changes and I exited but it doesn't change anything, I still get the same error.I should mention too that i can't access windows. – jean pierre Dec 23 '15 at 11:03
  • I downloaded boot repair, but when i try to run it, boot repair asks me to run the following commands into a terminal : pastebin.com/q5fq3CtU So I run them and when I click on forward, I get this error message : > "GRUB is still present. Please try again." Wich I searched for on internet but found nothing to solve my problem :/. Here is the log of my command line when i run the commands : pastebin.com/Yf8RPfad And here is my boot info : paste.ubuntu.com/14195663 – jean pierre Dec 24 '15 at 15:49
  • Which Linux distro did you install with Windows? Is it fedora or lubuntu? Do you have two separate hard drives in your system? I notice that you have linux installed on your /dev/sdb, the 2nd hard drive. Are you sure you set the boot priority to the hard drive that has just Linux installed then? Check the BIOS settings to see your boot priority and make sure it's set to the proper hard disk drive. – lakedejavu Dec 25 '15 at 8:52
  • To my memory, this is how I resolved my issue with dual boot, howtogeek.com/175641/… But I think yours doesn't find the boot loader in where it should be (sda, the first HDD). So try fixing the boot priority to "the right hard disk", with secure boot disabled, quiet boot enabled, no bootable usb attached to your system while booting. Other than all these, I am out of my knowledge. – lakedejavu Dec 25 '15 at 9:27
  • Also for the final try, grub2-install /dev/sdb or grub2-install /dev/sdc as I see two linux's installed. – lakedejavu Dec 25 '15 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.