2

I have a virtual machine on vmware ESXi 6.0 running Red Hat Enterprise Linux 7.2.

I have two network interfaces that I want to be named "eth0" and "eth1" respectively. They were originally named with the prefix "eno..." and then a string of numbers.

I edited the ifcfg files for both interfaces by changing the name and device parameters to "eth0" and "eth1".

I then renamed the ifcfg files to ifcfg-eth0 and ifcfg-eth1.

When I run systemctl restart network I get an error stating that the connection "eth0" is not available on the device "eno167".

enter image description here

It appears that the device name needs to be changed somewhere else in addition to the files in /etc/sysconfig/network-scripts/, where else could I verify that I need to change the network adapter name?

  • google udev rules eth0. at my iphone, wont be able to help for a while – Rui F Ribeiro Dec 22 '15 at 19:33
3

udev changed (ruined) it's interface naming scheme a while back. One of the easiest ways to get the old method back is to add 'net.ifnames=0' as a kernel parameter in your grub.conf file

  • 1
    Our build system ended up with both biosdevname=0 and net.ifnames=0 to stop these udev hijinks, regardless of whether on olden or newer releases, sigh. – thrig Dec 22 '15 at 19:44
  • I put both biosdevname=0 and net.ifnames=0 in the grub kernel parameters and then used ip link to set the names after rebooting and the network interfaces were successfully changed. Thanks! – Jonathan Kittell Dec 22 '15 at 21:49
2

Also worth noting if you don't like the new interface naming convention it is possible to name interfaces whatever you like.

In /etc/sysconfig/network-scripts/ create a file ifcfg-[desired-name]

Add:

DEVICE=[desired-name]
HWADDR=[mac address of the interface]

You can add all the usual settings to this file as well. This will name the interface whatever you like and pairs it up based on the MAC address of your device.

So if you wanted an interface named ftp-interface using the interface with a MAC address 00:00:00:00:00:00 and wanted it to have an IP 1.1.1.1/24 you could use:

/etc/sysconfig/network-scripts/ifcfg-ftp-interface
--------------------------------------------------

DEVICE="ftp-interface"
HWADDR=00:00:00:00:00:00
IPADDR=1.1.1.1
PREFIX=24

You can find more details about how the naming works on the Red Hat site: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Networking_Guide/sec-Understanding_the_Device_Renaming_Procedure.html

1

Centimane's method works also with centos 7 (redhat based).. Big thanks !

I also have in /etc/NetworkManager/NetworkManager.conf for plugings just plugins=ifcfg-rh , not keyfile.

this is/was the simplest way to change the interface name.. and I googled a lot!

of course NetworkManager will make a new interface so you have to configure it again... like disable dhcp from it.. so don't block your self out.

if you put just mac and new name to the ifcfg file NetworkManager will fill the rest.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.