1

Ristretto is the default picture viewer in XFCE. It starts the normal way when I start it manually from the menu but whenever it gets started as I double-click on a picture file to view it it starts maximized.

I don't think this is a good idea for an application to start maximixed by default and, as a matter of personal taste, I just hate completely maximized windows.

How can I possibly configure this?

0

At least with Ristretto 0.6.3, there's a preference for that. In the menu, select “Edit” → “Preferences”, go to the “Behaviour” tab, and untick the “Maximize window on startup when opening an image” checkbox. Ristretto remembers its last window size, so if it started maximized when you last opened it, it might occupy the whole screen (but not maximized) the next time; resize the window, and when you start it again it should stick at this smaller size.

The setting is stored in ~/.config/xfce4/xfconf/xfce-perchannel-xml/ristretto.xml. You can use this file to preset it to your desired window size.

<?xml version="1.0" encoding="UTF-8"?>

<channel name="ristretto" version="1.0">
  <property name="window" type="empty">
    <property name="height" type="uint" value="600"/>
    <property name="width" type="uint" value="400"/>
    <property name="maximize-on-startup" type="bool" value="false"/>
  </property>
</channel>
  • Thanks! It didn't even came into my mind it might have a preferences dialog :-) – Ivan Dec 24 '15 at 1:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.