0

I am working on a small project which requires Linux. So I made a live-usb for Ubuntu 14.04. I tried to install g++ and some other stuff but the apt-get does not work. It shows that I have unmet-dependancies. In fact, I cannot install anything.

What am I doing wrong? Should I make a persistent Live-usb? Or is it not possible to use apt-get in live environment at all?

My laptop is very shabby so I cannot boot into it because of serious hardware issues with my internal HDD. So live-usb is the only option I have.

Example of what happens:

root@ubuntu:~# sudo apt-get install build-essential
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 build-essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed
                   Depends: dpkg-dev (>= 1.13.5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The thing is, there are no broken packages.

5
  • What are you trying to install packages on to? A filesystem in memory? A hard drive? – Faheem Mitha Dec 20 '15 at 19:55
  • 1
    Did you run apt-get update to refresh the package lists first? Please edit your question to include a specific example of a package you tried to install, together with the complete error message. – steeldriver Dec 20 '15 at 21:02
  • Yeah, I did apt-get update. That does not help. And I want to install it in the SSD. – Saurabh Sinha Dec 20 '15 at 23:24
  • Either you didn't run apt-get update recently or your source list is broken or incomplete. Run apt-get update again, and if that doesn't help, post the content of /etc/apt/sources.list and of files in /etc/apt/sources.list.d – Gilles 'SO- stop being evil' Dec 20 '15 at 23:30
  • I removed some packages and re-installed them. Thanks for the help guys. – Saurabh Sinha Dec 21 '15 at 0:12
0

Have you tried aptitude instead of apt-get? BUT if apt-get isn't available that may not be either.

Also, do a search on "wget" and "git clone."

One last thing, is the Live with persistence? I'm no expert but that may make a difference.

1
  • No, the live is without persistence – Saurabh Sinha Dec 20 '15 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.