I can boot to my CD created using ubuntu. I boot to the archlinux x86-64 and it boots me into [rootfs /]# The error I am getting is the same error I am seeing in a lot of forums. ERROR: '/dev/disk/by-label/ARCH_201512' device did not show up after 30 seconds...

I have checked the label of the cd created it is correct. I have looked to try and find the folder by-label it does not exist. so by looking at several other forums primarily this one mounting problem during installation of archlinux on dell xps one and https://bbs.archlinux.org/viewtopic.php?id=142473 I have tried various combinations of the following commands to fix.

cd /dev ln -s sr0 archiso exit

this yielded same error

udevadm trigger which yielded different possible errors 754.659428 blk_update_request:I/O error, dev sr0, sector 1357824 754.792750 blk_update_request: I/O error, dev sr0, sector 1357824 754.794155 Buffer I/O error on dev sr0, logical block 169728, async page read

Ive never used ubuntu before to write a cd so maybe IT is the problem.

arcisodevice=/dev/sr0 exit yielded the first error of ERROR: '/dev/disk/by-label/ARCH_201512' device did not show up after 30 seconds...

What I am finding by running ls /dev/disk is by-id by-path by-uuid the by-label folder does not exist????

I have tried mv /dev/disk/by-label/ARCH_201512 /dev/disk/by-label/ARCH_201512 which yielded error of does not exist because the folder by-label does not exist I know that this command would have done nothing.

cd /dev ln -s sr0 /dev/disk/by-label/ARCH_201512 yielding no such file or directory so ... mkdir /dev/disk/by-label ln -s sr0 /dev/disk/by-label/ARCH_201512 exit no activity on drive and yielded same error I am going to remake the cd because of the I?O errors and will update. Any help here is appreciated. Haven't touched linux for ten years relearning alot.....

I made another cd using ubuntu using burnproof and I still see the same errors. grrr.... help ....

Next I will try the following... https://wiki.archlinux.org/index.php/Install_from_existing_Linux


Make the path first if it doesn't exist, perhaps you renamed the label before starting Arch Linux:

mkdir -p /dev/disk/by-label/

This makes a directory, including it's parents given the path provided.

ln -s <actual disk path> /dev/disk/by-label/ARCH_201512

This creates a symbolic link from the /dev/disk/by-label/ARCH_201512 to the <actual disk path> that the live image is looking for.

The file that needs to be linked is /dev/sr0 which is evident since I started a VM with Arch Linux boot media.

Lastly: Type exit to have the live image check for the path again. Then you should be ready to continue with installation.

| improve this answer | |

I hate to Necro this post. But, I have been searching for HOURS trying to find a fix for this, and I just wanted to post my thanks. Maybe others will find this useful as well. Bradley Kennedy's answer worked wonderfully.

I was trying to load into FWUL (Forget Windows Use Linux) from a LIVE DVD that I burned with Windows 10 using imgBurn. I tried all of the different fixes I could find. This worked beautifully.

Tab to edit after GRUB loads.

mkdir -p /dev/disk/by-label/
ln -s /dev/sr0 /dev/disk/by-label/FWUL
| improve this answer | |
  • Thank you, this was the solution for me! I was having trouble installing Manjaro, but aside from changing FWUL to what it was looking for, this was exactly what I needed. – NintendoZaedus Jun 17 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.