2

I know the question looks similar but I did not find any answer to my problem, hence posting it here. Thanks in advance for any help.

I had Ubuntu 14.04 installed alongside Windows 8.1 and both showing up in boot sequence (with UEFI - 'Enabled', Fast Boot 'Disabled' and Secure boot - 'Disabled').

However, to run a web application (not supported in Ubuntu 14.04), I installed Ubuntu 12.04. Installation was done by enabling 'Legacy Support' and 'Legacy First' in BIOS.

After installation, I can see all three (12.04, 14.04 and Win 8.1) in the boot menu when 'Legacy Support' is enabled in BIOS. However, only 12.04 and 14.04 works. If I try the Windows option, I get an error.

If I turn on 'UEFI' in BIOS, I can boot 14.04 & Win 8.1 successfully. However, 12.04 is not showing up even in the generic options (12.04 is Ubuntu 13.03.74 or something - Sorry, cannot remember the exact nomenclature).

Tried boot-repair (both ways - installed in Ubuntu and as a start up USB). When run from terminal, it gives an error and asks me to run in USB as a start-up disk. When run in USB, the disk is ignored with USB boot Enabled in both modes (UEFI as well as Legacy).

Thanks again.

  • Is the bootloader grub? What version? – Tom Zych Dec 19 '15 at 9:48
0

You are using the grub version from 14.04 LTS, and you install Ubuntu 14.04 and Windows 8 in UEFI mode. so first, if Windows 8 run in UEFI mode, never will run in Legacy mode, Windows changes the boot for UEFI and never will return to Legacy Mode.

Now for Ubuntu 12.04 LTS, you need a 64 bits (AMD64) version to run in UEFI mode, 32 bits (i386) don't run with UEFI enabled (https://bugs.launchpad.net/ubuntu-cdimage/+bug/1025555)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.