5

I would clone my partition /dev/sda1 on Ubuntu 14.04.
I've downloaded Clonezilla in order to clone this partition and be able to reinstall it later.

As recommended on the CloneZilla's website, I used Tuxboot to install a CloneZilla iso on my USB key.

I've started my PC from the USB key, it worked and I saw a GRUB-like menu that contains a list of boot modes.
The problem is the following, I can't boot in any mode, I have the following error:

overlayfs: missing 'workdir'

I have no idea about the problem it is the first time I try to clone a partition.

6

This probably has to do with the fact that a for a ready only mount (which is probably the case for a clonezilla usb key) a workdir is not needed and is left blank in the OverlayFS mount config. Thus the notice is saying that it is missing, but in this case that is nothing to worry about.

You can just go ahead and clone your partition!

  • I can't just clone my partition, the error about workdir blocks all and nothing happend after that. Maybe the overlays config has changed in the new version ? (no idea) – AnthonyB Dec 19 '15 at 8:46
  • Finally I tried again, and after the error missing 'workdir', I wait 15 or 20 minutes, and it worked. I don't know why there was no message, but your advice was right ! Thank you – AnthonyB Dec 19 '15 at 15:08
2

I just downloaded the stable version and had the same error as you. I tried to used a previous version, it displayed the message but immediately continued. I suspect we have some incompatibility with the latest version.

  • It is possible indeed. An incompatibility with the kernel they use maybe. But it worked, I cloned and restored my partition. – AnthonyB Dec 21 '15 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.