Question: I recently installed RHEL 7.2 and.. the icons on the desktop are HUGE. How can I decrease their size?


Run this in a terminal :

gsettings set org.gnome.nautilus.icon-view default-zoom-level small
| improve this answer | |
  • 5
    Additionally, on Centos 7 (the current release 7.4.1708 while typing this comment), this gives the list of all icon size options: gsettings range org.gnome.nautilus.icon-view default-zoom-level. – Celdor Sep 22 '17 at 10:09

enter image description here

Just go to "dconf-editor", then org -> gnome -> nautilus -> icon-view, and set the default-zoom-level small

| improve this answer | |
  • 2
    Also note that nautilus now has this option built in – smac89 Dec 22 '16 at 23:09

One more way how to change the size of desktop icons is directly from Nautilus:

  • Open nautilus
  • change the way of displayed icons to icon view NOT detailed view!
  • zoom icons using Ctrl + mouse wheel

While zooming the icon view the icons are changed on the desktop at the same time.
Zooming is not reflected while using detailed view!

Edit: If you're on a laptop without scroll wheel, use Ctrl + +, or Ctrl + -, to increase or decrease icon size.

| improve this answer | |
  • the most simple solution here. – H Aßdøµ May 29 '18 at 18:26
  • This answer is highly useful - especially because it shows how "accidentally" the icons on the desktop got too big in the first place. It's not that uncommon to change the icon-size in Nautilus (especially since for some file-types Nautilus shows a preview) and if the desktop was not visible at the same time, one would never realise why or when it changed. – Dweia Jan 6 at 16:27

Going below 48px requires changing the Nautilus source code and recompiling. (Yes, they hard-coded icons sizes.)


  1. Install the following dependencies:
    • libgd-dev
    • autotools-dev
    • libexif-dev
    • libexempi-dev
    • libselinux1-dev
    • libtracker-sparql-1.0-dev
    • libext-dev
    • libxml2-dev
    • libgnome-desktop-3-dev

Each one installs a bunch of other stuff, so hopefully I've given you the correct parent package name. I apologize for not recalling with 100% accuracy exactly what I installed, but this looks fairly correct to me immediately after my install. (Notify me if I'm inaccurate anywhere.)

  1. Download the version of Nautilus that you are currently using from the Nautilus snapshots website. To find that out, run nautilus --version from the terminal. After downloading the archive, unzip it to whatever directory you want to work from.

  2. From within the unzipped package, open the file nautilus-icon-info.h. Within the first several lines you will see various sizes designated for the particular scroll-setting options. For instance, within the file for version 3.20.4 the icon sizes start on line 36. Change each of those levels to whatever you want to use so that you can make the icons much smaller (or larger).

  3. After editing and saving the file, it's time to configure, compile, and install. Run the following commands from the terminal from within the base directory of the version of nautilus that you have downloaded and unzipped. Make sure that you are within the base of the folder structure of the nautilus directories!

    sudo make install

This can be run altogether with the command ./configure && make && make install.

If the ./configure command fails, it's because you are missing some other dependencies. I apologize if my list of dependencies above was incomplete. Google (or whatever search engine you want) to find what package it is that you need. You can use Synaptic to search for what you need if you're unsure even after Googling.

Once installed, I suggest a reboot just to make sure that every single thing is reloaded properly. You can now tweak with your icon sizes as you wish.

Have fun!

| improve this answer | |

This solution was design to address the issue in rhel 7.4 but might also be relevent here. There seem to be a design decision regarding icons size acroding to this link. but that looks to me like a bug: https://bugzilla.redhat.com/show_bug.cgi?id=1478153

there is also a solution sugested here: https://access.redhat.com/solutions/3138541

But eventually what i did to address this is as followed:

sed -i '/default-zoom-level/{n; s/large/standard/} '  /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.xml && glib-compile-schemas /usr/share/glib-2.0/schemas/ >/dev/null 2>&1
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.