1

I'm trying to enable kvm-virtualization for Android virtual devices. In order to do so, I followed this guide and did the following:

  1. Checked, if kvm-virtualization is available:

    user $ grep --color -E "vmx|svm" /proc/cpuinfo
    flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt
    
  2. Enabled Vt-x in BIOS;

  3. Added support in kernel via setting CONFIG_KVM and CONFIG_KVM_INTEL modules as built-in modules in genkernel --menuconfig all;
  4. Emerged package app-emulation/qemu.

However, when I try to run it, I get the following:

user $ qemu-system-x86_64 -enable-kvm
Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory

And as title says, there is no /dev/kvm file. How can I fix this problem?

EDIT: /proc/cpuinfo content

  • paste the contents of /proc/cpuinfo please. – schaiba Dec 16 '15 at 14:21
  • @schaiba added /proc/cpuinfo contents – Mikhail Dec 16 '15 at 14:25
  • What does dmesg | fgrep -i kvm say? – user140866 Dec 16 '15 at 18:49
  • @siblynx well, it's empty – Mikhail Dec 17 '15 at 7:12
  • Sounds like you still running an old kernel or you'd configured kvm support as a loadable modules rather than statically linked into kernel... – user140866 Dec 17 '15 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.