0

I have a Windows 8 / Ubuntu dual boot system.

When I open kali, I can't see any of the hard disk partitions. I receive the following error message:

Error mounting /dev/sda1 at /media/root/windows: Command-line `mount -t "ntfs" -o "uhelper=udisks2,

nodev,nosuid,uid=0,gid=0,dmask=0077,

fmask=0177" "/dev/sda1" "/media/root/windows"'

exited with non-zero exit status 14:

Windows is hibernated, refused to mount.

Failed to mount '/dev/sda1': Operation not permitted

The NTFS partition is in an unsafe state. Please

resume and shutdown Windows fully

(no hibernation or fast restarting), or mount the volume

read-only with the 'ro' mount option.

My /etc/fstab file is

root@joe:/etc# cat fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=8b18065b-bf87-4901-bf63-5160373ec384 /               ext4    errors=remount-ro 0       1
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0

I have not hibernated Windows, I made a full shutdown. Still, I get this error message:

dskchk in Windows:

Microsoft Windows [Version 6.3.9600]

(c) 2013 Microsoft Corporation. All rights reserved.

C:\Windows\WinSxS\x86_microsoft-windows-commandprompt_31bf3856ad364e35_6.3.9600.

16384_none_1fac8b4435f61ead>dskchk

'dskchk' is not recognized as an internal or external command,

operable program or batch file.

C:\Windows\WinSxS\x86_microsoft-windows-commandprompt_31bf3856ad364e35_6.3.9600.

16384_none_1fac8b4435f61ead>chkdsk

The type of the file system is NTFS.

Volume label is windows.

WARNING! F parameter not specified.

Running CHKDSK in read-only mode.

Stage 1: Examining basic file system structure ...

457216 file records processed.

File verification completed.

1000 large file records processed.

0 bad file records processed.

Stage 2: Examining file name linkage ...

535184 index entries processed.

Index verification completed.

0 unindexed files scanned.

0 unindexed files recovered.

Stage 3: Examining security descriptors ... Security descriptor verification completed.

38985 data files processed. CHKDSK is verifying Usn Journal...

39528320 USN bytes processed.

Usn Journal verification completed. The Volume Bitmap is incorrect. Windows has checked the file system and found problems. Please run chkdsk /scan to find the problems and queue them for repair.

102265855 KB total disk space.

83621268 KB in 209367 files.

147684 KB in 38986 indexes.

    0 KB in bad sectors.

570671 KB in use by the system.

65536 KB occupied by the log file.

17926232 KB available on disk.

 4096 bytes in each allocation unit.

25566463 total allocation units on disk.

4481558 allocation units available on disk.

C:\Windows\WinSxS\x86_microsoft-windows-commandprompt_31bf3856ad364e35_6.3.9600.

16384_none_1fac8b4435f61

Chkdsk/scan result:

Microsoft Windows [Version 6.3.9600] (c) 2013 Microsoft Corporation. All rights reserved.

C:\Windows\WinSxS\x86_microsoft-windows-commandprompt_31bf3856ad364e35_6.3.9600. 16384_none_1fac8b4435f61ead>chkdsk/scan The type of the file system is NTFS. Volume label is w.

Stage 1: Examining basic file system structure ...

457216 file records processed.

File verification completed.

1000 large file records processed.

0 bad file records processed.

Stage 2: Examining file name linkage ...

535166 index entries processed.

Index verification completed.

0 unindexed files scanned.

0 unindexed files recovered.

Stage 3: Examining security descriptors ...

Security descriptor verification completed.

38976 data files processed.

CHKDSK is verifying Usn Journal...

39632264 USN bytes processed.

Usn Journal verification completed.

Windows has scanned the file system and found no problems.

No further action is required.

102265855 KB total disk space.

83435980 KB in 209375 files.

147684 KB in 38977 indexes.


    0 KB in bad sectors.

570735 KB in use by the system.

 65536 KB occupied by the log file.

18111456 KB available on disk.

  4096 bytes in each allocation unit.

25566463 total allocation units on disk.

4527864 allocation units available on disk.

C:\Windows\WinSxS\x86_microsoft-windows-commandprompt_31bf3856ad364e35_6.3.9600.

16384_none_1fac8b4435f61ead>

  • run chkdsk in windows – paul Dec 15 '15 at 8:00
  • @paul the chkdsk result is update . Look up – Joe_Vj _95 Dec 15 '15 at 8:23
  • Windows has checked the file system and found problems. Please run chkdsk /scan to find the problems and queue them for repair. – paul Dec 15 '15 at 8:40
  • How to queue and repair – Joe_Vj _95 Dec 15 '15 at 8:48
  • As windows said: "run chkdsk /scan". Before try "chkdsk /f" – paul Dec 15 '15 at 8:51
2

The solution is already in the error message you offer:

Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.

Even if you "fully" poweroff or shutdown the computer, Windows may hilbernate. So just mount the Windows partition as read only (add ro flag in the item of the Windows partition in your /etc/fstab file).

PS there're already many questions being asked about this:

https://askubuntu.com/questions/280530/how-do-i-mount-a-hibernated-partition-with-windows-8-in-ubuntu

  • I cant mount my drives ( C, D,E ) – Joe_Vj _95 Dec 15 '15 at 8:58
  • @Joe_Vj_95 you need to know the device name of (C, D, E) in Ubuntu Linux, should be like /dev/sdaX. Say the C disk in WIn8 is /dev/sda1, you can mount it manually by sudo mount -t ntfs-3g -o ro /dev/sda1 /mnt/C – bigeast Dec 15 '15 at 9:02
  • How can i find the device name ? – Joe_Vj _95 Dec 15 '15 at 9:04
  • I need to mount it in read write mode – Joe_Vj _95 Dec 15 '15 at 9:04
  • You can use the output of lsblk or df to 'guess' the device name. Sorry I can't help if you want it be read write. It's Windows's problem, perhaps you need to config your Windows somehow. – bigeast Dec 15 '15 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.