3

I am using PulseAudio to manage my sound on Debian 8 with i3wm.

Everything works properly, except the volume level on my on-board sound card. I can get sound out of it if I crank all settings to max (153% volume on both input and output on pavucontrol) and turn my speakers up pretty loud. The expected audio is played, just very quietly.

The setting is on "analog stereo output" everything is recognized and acts appropriately, except the volume.

I have a USB headset that works fine with the correct volume when selected in pavucontrol. When I boot into Windows, sound is fine.

This used to work properly with the correct volume, then stopped. My guess is that it was an update, but I don't use sound that often and am not able to correlate the events. There may also have been a reboot in there.

I have already killed the configs and restarted pulse. I've tried a few other troubleshooting steps, but none have yielded any results.

I can provided any data / logs requested, not sure what to look at at this point. I've played around in pacmd, but didn't find anything useful in there.

So I guess my question is, is there a baseline volume setting that is being set or calculated that is incorrect for my sound card that I can set statically? Or what in the world else could be happening here.

amixer output:

$›amixer                                                                                                                                     
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 103525 [158%] [on]
  Front Right: Playback 103525 [158%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 65536
  Mono: Capture 55141 [84%] [off]

alsamixer cap:

alsamixer settings more alsamixer settings

Link to amixer -D hw:0 contents: http://pastebin.com/bB7ERZ13

  • 1
    Try amixer -D hw:0 or hw:1... one of those should get the actual sound hardware. You ran amixer on PulseAudio, via the ALSA plugin. Even better would be to pastebin amixer -D hw:0 contents (or again hw:1) somewhere... Also, this appears to not be a PulseAudio problem, but an ALSA one. – derobert Dec 15 '15 at 18:45
  • 1
    If you do a pasuspender -- speaker-test -D hw:0 -c 2 -t wav (or again hw:1), could you confirm that's also quiet? If so, this is actually an ALSA issue, not PulseAudio. – derobert Dec 15 '15 at 18:47
  • Added a link to the "amixer -D hw:0 contents" command in original post. The speaker test also yielded very low audio, similar to playing sound from another input (chrome or spotify for example). – eficker Dec 15 '15 at 21:31
  • 1
    One more question... Which port do you have your speakers plugged in to? It's possible that Linux is outputting sound to a different port, and the faint audio you're hearing is actually bleed through. Most modern sound hardware is fully configurable as to which port is for what (and even if a port is input or output). Try the speakers in each port... Make sure to turn down the volume on the speakers first, though, I bet one of the ports has the full volume audio you're looking for. – derobert Dec 15 '15 at 22:06
  • Can you make this an answer (solved my problem) then I can mark it as the solution. How it worked on the normal line out (green) and now is on the rear speaker jack (blue) I have no idea. :/ You're awesome, thanks! – eficker Dec 15 '15 at 22:22
3

On many modern sound cards, port mapping is fully configurable: you can, in software, configure each physical port to be either input or output, and whatever output or input you'd like. This, unfortunately, means that sometimes different OSes (and sometimes even releases of OSes) default to different mappings.

In short: Windows is using different port than Linux. The very low volume audio you're hearing is bleed-through from the port Linux is driving.

The easiest fix is probably to use Linux's default port, then (if you want it to work in Windows) I think when you plug in your speakers while running Windows, Windows will ask you what you just plugged in—and it'll then configure itself to match Linux's default. I think you can do the config under Linux as well (to change Linux's default mapping), but AFAIK there is no friendly way to do so.

  • 1
    Great answer, and solved my issue. Thank you! The only troubling thing is that it somehow reconfigured itself to use the rear port without making any changes. But its working and I believe your approach is correct on leaving it working in linux and let windows adapt. I only pop over to windows to play a game occasionally, so I think i'm good to go now. Thanks again! – eficker Dec 15 '15 at 22:39
  • 1
    The "bleed-through" is probably just the actual audio from another channel. Such as if you have 7.1 channel audio configured and are using the outputs confirmed for the surround speakers instead of the main speakers. – freb Dec 15 '15 at 22:45
  • 2
    @freb yep, that's what I mean. Bleed-through is from the outputs not being fully isolated from each other. Some form of electrical or electromagnetic coupling between the output channels. (Isolation costs money, and at some point you say good enough and stop spending money.) – derobert Dec 15 '15 at 22:48
2

Start alsamixer and also set the volume there. That should do the trick.

  • Beat me too it! I agree with this solution. – Cameron Verotti Dec 15 '15 at 9:15
  • alsamixer is not installed, can it still influence the volume settings? – eficker Dec 15 '15 at 16:58
  • installed alsa-utils, ran alsamixer, its settings reflected the volume level of pulse (153% volume). Actual audio output, unchanged – eficker Dec 15 '15 at 17:02
  • @eficker Press F6 and switch to the other soundcards? – Jodka Lemon Dec 15 '15 at 18:09
  • Yep, did that and selected my internal card, cranked up all the vols for all the items there. I'll put a screen cap in my orig question, see if anything looks amiss. – eficker Dec 15 '15 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.