1

I set my proxy to 127.0.0.1:3128, and then I added this to the configuration file:

acl blocked_sites url_regex -i "/usr/local/etc/squid/blocked_sites"
http_access deny blocked_sites
http_access allow all

Here is /usr/local/etc/squid/blocked_sites

facebook

This should deny all requests to urls containing "facebook". However, I am able to access facebook from my browser. But often, I am not even able to access any website at all, let alone use such functions.

This is what it looks like in /usr/local/var/logs/access.log when I access facebook.com from my browser:

1450045715.071 1449 127.0.0.1 TCP_TUNNEL/200 134759 CONNECT www.facebook.com:443 - HIER_DIRECT/31.13.93.36

How do I fix this?

I have confirmed the squid process is running with pgrep and looking in the Activity Monitor.

I have also tried adding:

acl blockeddomain dstdomain "/usr/local/etc/squid/blocked_sites.acl"
http_access deny blockeddomain

To my squid.conf. Here is blocked_sites.acl

facebook

I have also tried adding .com to the url list, and stuff like url_regex -i to the conf file, but it didn't change anything.

  • What does the squid access.log file show you is happening when you browse? – roaima Dec 14 '15 at 0:06
  • @roaima lines like this 1450045715.071 1449 127.0.0.1 TCP_TUNNEL/200 134759 CONNECT www.facebook.com:443 - HIER_DIRECT/31.13.93.36 - – DisplayName Dec 14 '15 at 13:35
  • 1
    You did restart squid after adding facebook to your blocked_sites file? – roaima Dec 14 '15 at 16:20
  • @roaima Yes, I added that before I started squid the first time, and I restarted multiple times after. – DisplayName Dec 14 '15 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.