I am trying to boot linux mint from a server I set up in virtualbox. Server is running in linux mint, and the client that I'm testing on (also virtualbox) is disk-less and booting over network. After splash screen vmlinuz and initrd are received correctly, until I get the following error:


Any info on what might be going wrong?

  • seems like an address for an entire network, not for a specific server. What config files have that address? Dec 13, 2015 at 16:10
  • @MarkPlotnick I have two interfaces. eth0 on NAT and eth1 on internal network. eth1 is on address with netmask I am using dnsmasq and the config files that has that adress is the default config file that I have in /srv/tftp/pxelinux.cfg
    – mythic
    Dec 13, 2015 at 16:19

4 Answers 4


As Mark Plotnick pointed out, the most likely cause for this error is network misconfiguration: your eth1 interface has been configured with the invalid address

Unfortunately, this was not my case. I was trying to make a Raspberry Pi 3 boot from NFS and my network, hosts and NFS shares were configured correctly. After having seen a whole range of obscure errors like:

Begin: Retrying nfs mount ... short read: 24 < 28
NFS over TCP not available from [Server IP address]
pmap_getmaps.c: rpc problem: RPC: Authentication error; why = Client credential too weak
mount: RPC: Remote system error - Connection refused

I finally found the answer here (but it was also at hand here).

There was no mismatch between NFSv3 and NFSv4 in nfsd.ko module in the RPI3 kernel tree, nor it was a problem of architecture or whatever. It was simply a matter of allowing RPCs coming from my test subnetwork inside /etc/hosts.allow, like this:

#> cat /etc/hosts.allow 

rpcbind mountd nfsd statd lockd rquotad :
  • Correct answer for me. May 26, 2020 at 13:07

Add SYSAPPEND 3 to your config file in pxelinux. This will append ip= and BOOTIF= parameters to the kernel. See documentation here: https://wiki.syslinux.org/wiki/index.php?title=SYSLINUX#SYSAPPEND_bitmask



I had the same problem with Ubuntu Focal Fossa 20.04.1 LTS

I know that the question is very old, but I don't mind :D

LABEL Ubuntu 20.04.1 LTS (Focal Fossa)
  kernel /tftpboot/ubuntu/amd64/casper/vmlinuz
  append vga=normal netboot=nfs boot=casper ip=dhcp nfsroot= ro initrd=/tftpboot/ubuntu/amd64/casper/initrd locale=de_DE bootkbd=de console-setup/layoutcode=de

I forgot the "ip=dhcp" mentioned in the https://bugs.launchpad.net link above.

hope this helps


This happened to me on Ubuntu 18.04 but with an updated 5.4 kernel to allow exporting overlayfs.

First to get rid of "Connection refused" I had to run:


Then I got the above message. Simply restarting the NFS after that worked. Not sure what config files i need to update yet or if it's going to work after a reboot. Will report back.

/etc/init.d/nfs-kernel-server restart

I also had to run:

systemctl restart rpcbind
  • Worked fine after reboot too. So it's just necessary to make active any changes you made to /etc/exports.
    – Dagelf
    Nov 17, 2021 at 20:27
  • ie. just exportfs clearly isn't enough anymore :-/
    – Dagelf
    Nov 17, 2021 at 21:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .