1

I'm little bit worried about this (note the 99% used space in the root):

$ df -h
File System                     Size  Used  Free Use% Mounted To 
/dev/mapper/scientific-root      50G   50G  735M  99% /
devtmpfs                        7,8G     0  7,8G   0% /dev
tmpfs                           7,8G   80K  7,8G   1% /dev/shm    
tmpfs                           7,8G   89M  7,7G   2% /run
tmpfs                           7,8G     0  7,8G   0% /sys/fs/cgroup
/dev/md124                       11T  8,0T  2,4T  78% /data
/dev/mapper/scientific-home     408G   41G  367G  10% /home
/dev/md126p1                    497M  213M  284M  43% /boot

This situation has arisen unexpectedly as the root has always had ~30% used space. I suspect some unwanted logs have been filling it up. But here's the thing, when I run du / even as super user, I can't seem to find 50G worth of files in root.

Do you have any suggestions where to look? Are there any good tools to pinpoint the culprit?

Thanks a bunch,

Peter.

  • 3
    lsof +L1 might be a starting point (find files that are deleted but not yet freed because they're kept open by a process). If you've had problems with your mounts recently, it could also be that somebody dropped a few gig in /data when it was not mounted. (The mount point is still a directory.) You'd not see those files after mounting /dev/md124 over it. – Ulrich Schwarz Dec 13 '15 at 12:03
  • @UlrichSchwarz thanks, I've attached the lsof +L1 output here: pastebin.com/YFV4qMmQ. I find theory that /data might contain some files as a directory most plausible. I will try unmounting it and listing its files shortly. – Petr Mánek Dec 13 '15 at 13:09
  • You might get away without unmounting if you bind-mount the root filesystem to a different additional mountpoint. (But I've never done that for /.) – Ulrich Schwarz Dec 13 '15 at 20:04
3

Try installing the ncdu package, if you can. (run the yum clean all command to temporarily free up some quick space for installing it.)

Once installed run this command:

ncdu / --exclude /home --exclude /boot

It's like the treesize.exe utility in windows and will guide you to the exact location of the problem

  • 1
    @OP: you should do well with this, but remember running it as root. – 41754 Dec 14 '15 at 10:16
  • I ran it as root and it did not find any big directories; got pretty much the same output as from du. After reviewing several threads, I believe that the output of df might be a bit misleading as to its real meaning. Anyway, I will keep this handy utility around, it's really user-friendly! – Petr Mánek Dec 15 '15 at 22:03
1

You are in a situation where something started to eat space under var or tmp.

Do # du -sh /* 2>/dev/null.

Your next GNU/Linux installation will have separate /, /usr, /var and /tmp partitions.

  • I have executed this command with the following output: pastebin.com/x4R0JLfF The only thing capable of generating ~50GB of space is the /home directory which is mounted on separate 500GB drive. So, how do I proceed? – Petr Mánek Dec 13 '15 at 13:16
  • I edited for you to be able to get complete output (you are missing some items by not using it as root) and for error messages not to be printed. Try again, however using ncdu is a very good solution too. – 41754 Dec 14 '15 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.