2

I bought a new computer some time ago.. I installed nvenc for ffmpeg to encode my videos with the h264 codec. To optimize i used the

-crf option

but something went wrong..

I want to encode a full hd video with originally 6000kbits but ffmpeg encode the video with crf to max 1800kbits.. thats really less and you can see this in the video after the encoding..

I also used

-crf 0

already but it didn't help.. What can i do to force the bitrate to at least 3000kbit but with the -crf option.. i don't want to use a fixed bitrate!

Thanks for your help!

1

ffmpeg -y -i inputfile -c:v nvenc_h264 -b:v 1000k -minrate 500k -maxrate 5000k -tier high -profile:v high -level 4.0 -preset llhq <outputfile>

You will be limited with what options you can use. Faster encodes yes. Quality and control? Not so much. The above example might help you a bit. The -b:v 1000k -minrate 500k -maxrate 5000k being the most important part.

0

nvenc doesn't accept crf

it has its own parameters, taken from ffmpeg help [ffmpeg -h encoder=nvenc]:

-preset... Set the encoding preset (one of slow = hq 2pass, medium = hq, fast = hp, hq, hp, bd, ll, llhq, llhp...)

which means something like: -c:v nvenc -preset hp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.