5

I've bought msi gs40 that has intel i7 6700HQ which means integrated graphics hd 530. After a day of struggling I was able to start xorg with HD530. For this I addes i915 to initramfs and i915.preliminary_hw_support=1 to kernel params. But xorg hangs in the end of the day, sometime right after start, sometimes after a few hours of using. I tried archlinux with:

  • xorg 1.6, 1.7, 1.8
  • kernels 4.2.5-1, 4.3, 4.4-rc4, 4.4-rc5
  • cinnamon, plasma5
  • latest intel driver in archlinux repository and compiled intel driver from git.
  • Arch wiki suggestion: intel_idle.max_cstate=1 and Xorg Option "DRI" "False"
  • ubuntu and Linux Mint (both freeze right after start). OS Windows runs fine.

Everything just freezes after some time of using and I got glib stacktrace in journalctl(meanwhile xorg.log and dmesg are fine) Sometimes I get couldn't open dis display :0 in dmesg and applications refuse to start. journalctl kde's shows Bad windows, cinnamon's other errors. Here's the dmesg of system startup with 4.4-rc5 kernel without external displays.

  • There are no errors in dmesg and xorg when xorg hangs if I work only with laptop's display (just DE errors described above).
  • If I run HDMI/DP external display I would also get dmesg stacktrace like a bonus when Xorg hangs, looks like this bug issue.

Related topics:

  • Mine question on Archlinux forum
  • The guy from askubuntu was able run HD530 from the same cpu (6700hq) with LinuxMint. I tried the same, didn't work.

If you require additional information please tell me. Any kind of help is greatly appreciated!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.