0

My OS is Xubuntu 14.04 and if you are using it too, you've surely noticed that when internet connection is established, it gives a notification by default at the top right corner of monitor. It has a button Don't show notification and I pressed it accidentally. Now I missed the notifications so much and want it back! Does anybody know where is its setting to give it back?

I tried notifications panel in settings, but no change was observed.

  • 1
    This old post on Ask Ubuntu had asked similar question, from which I had adapted to restore notification when internet connection is established. Additionally, I have briefly covered for other network notification cases. Answered below. – clearkimura Dec 12 '15 at 18:58
1

Yes, the notification setting can be restored via gsettings. The reason you didn't find the setting is because the it is not stored by Xubuntu notification daemon xfce4-notifyd.

Reset network notification

The easiest way is to reset the network notification to default setting from command line. The following one-line command will restore notification when the Internet connection is established.

In the Terminal, type the following command and press Enter key.

gsettings reset org.gnome.nm-applet disable-connected-notifications

The effect is immediate, so restart is unnecessary.

To see the notification, click on the indicator icon for networking in the Xfce panel, then select/deselect Enable Networking option. The notification will show up again as usual.

Extra: Other network notifications

In case you accidentally pressed the Don't show this message again button for other network notifications, you can list them by running the following command.

gsettings list-keys org.gnome.nm-applet

The output will show list of keys as below.

stamp
disable-disconnected-notifications
disable-vpn-notifications
disable-connected-notifications
suppress-wireless-networks-available
show-applet
disable-wifi-create

Look for relevant ones that have notifications keyword. Then run the reset command with the key you wish to reset.

gsettings reset org.gnome.nm-applet [KEY]

Alternatively, you can choose to enable notification manually by running the set command with false option. Since the key names are named as disable-, the false option is correct.

gsettings set org.gnome.nm-applet [KEY] false

Both methods have been tested working in Xubuntu 14.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.